Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Visual Studio 2019 for Mac not opening files from Unity

Discussion in 'External Tools' started by Senshi, Mar 30, 2020.

  1. Senshi

    Senshi

    Joined:
    Oct 3, 2010
    Posts:
    534
    EDIT: Seems a full system reboot fixed it this time.

    --------

    I am slowly losing my mind over this. Ever since a few days ago I can no longer open any files (C# or shaders) directly from Unity. The first one or two attempts it will open VS or bring it to the foreground if it's already open, but it won't open the selected file, nor jump to the correct line (when clicked from the Console with the correct file already open). Any further attempts will cause Unity to hang and become unresponsive.

    Things I've already tried:
    • Deleting the .sln and .csproj files
    • Deleting and rebuilding the project's Library folder
    • Deleting the project's .vs folder
    • Updating VS to the latest version
    • Assigning and reassigning the external script editor in the Unity preferences
    Environment:
    • Visual Studio 2019 for Mac (Version 8.5 (build 3183))
    • Unity 2018.4.13f1
    • MacOS 10.13.6
    History
    Around 2 weeks ago I decided to upgrade from VS 2017 to 2019. This went smoothly, but as I hated the new Intellisense I tried downgrading back. I couldn't get this to work as the reinstalled VS 2017 couldn't find any types or namespaces (threw error The type or namespace System can't be found and all namespaces were greyed out).

    I finally gave in and just rolled with 2019 for a while, which has now kicked the bucket as well. I haven't touched any settings or installs since then.

    ...Can someone please save my sanity?
     
    Last edited: Mar 31, 2020
unityunity