Search Unity

Visual Studio 2013 Pro with Unity 5.2

Discussion in 'Editor & General Support' started by bigbadtrumpet125, Sep 8, 2015.

  1. bigbadtrumpet125

    bigbadtrumpet125

    Joined:
    Apr 1, 2013
    Posts:
    18
    I just upgraded to Unity 5.2 and I am currently using Visual Studio 2013 Professional edition. Our company is to large to be able to legally use 2015 community so upgrading is not currently an option. With the tight integration with Visual studio 2015 community it appears it has broken my ability to debug with VS 2013 Professional. Is there a setting that could possibly fix this? I have tried deleting the UnityVS tools stuff but VS 2013 still opens without the ability to attach to Unity. Any possible solutions?
     
  2. jtsmith1287

    jtsmith1287

    Joined:
    Aug 3, 2014
    Posts:
    779
    Oh gosh. So glad I found this. I will await a response from devs before I update to 5.2 Yikes. I hate these kinds of issues. I just don't have time to deal with it.
     
  3. TehGM

    TehGM

    Joined:
    Nov 15, 2013
    Posts:
    89
    I also would like devs feedback on this. While I can upgrade to 2015, I don't want to *yet*. For now I'd like to stick to my 2013 Ultimate (being IT student, ow yeah).
    I've never used UnityVS before, but I was pretty excited about it being added to unity itself.
    Hopefully it's not restricted to 2015 only.
     
  4. Hodgson_SDAS

    Hodgson_SDAS

    Joined:
    Apr 30, 2015
    Posts:
    123
    I am also in your shoes. I've noticed that 2015 works well, but when I change it to 2013 it only opens mono
     
  5. Barkers-Crest

    Barkers-Crest

    Joined:
    Jun 19, 2013
    Posts:
    154
    I'm getting the 2013 opens to mono thing as well.
     
  6. Hodgson_SDAS

    Hodgson_SDAS

    Joined:
    Apr 30, 2015
    Posts:
    123
  7. Barkers-Crest

    Barkers-Crest

    Joined:
    Jun 19, 2013
    Posts:
    154
    Thanks for linking me to that thread. I was able to get things back in order based on some of the information there!

    Basically, I ended up uninstalling all VS Tools, removed UnityVS folder from project, reinstalled VS Tools, and then reboot.

    Before those steps I didn't have the Visual Studio information in the About box, now I do.

    Things are working well now. Thanks again.
     
  8. burtonposey

    burtonposey

    Joined:
    Sep 8, 2009
    Posts:
    60
    Barkers, did you install the VS Tools through the MS site or through the 5.2 installer? I'm currently uninstalling the VS 2015 Community as I have 2013 Professional and had no plans on switching (or spending most of my day trying to fix this problem).

    This issue is quite annoying. It's apparently choosing VS 2015 Community over 2013, despite my settings saying 2013. I think I had nuked my solution files as well. Hopefully uninstalling it altogether and installing the VS tools for 5.2 via the separate installer (not the Unity 5.2 installer checkbox) will fix things. What a mess.

    Thanks for any feedback you can provide on which method you used to restore order on your machine.
     
  9. Barkers-Crest

    Barkers-Crest

    Joined:
    Jun 19, 2013
    Posts:
    154
    I installed through Visual Studio -> Tools -> Extensions and Updates, which pulled down an installer from what I would assume to be the Visual Studio Gallery website.

    To be clear, I did end up moving to VS 2015 Pro and have not tried opening in VS 2013 since.

    Did you check the thread Hodgson linked to? There is information in there about what you should expect to see in the bottom left of the Unity -> Help -> About Unity dialogue window.

    Before the uninstalls of VS Tools I did not see the expected message. After uninstall/clean install I did see the message and things have been fine since. Make sure you wipe out your UnityVS folder in assets as well.
     
  10. burtonposey

    burtonposey

    Joined:
    Sep 8, 2009
    Posts:
    60
    I think your solution is the same conclusion I came to... you cannot use VS 2013 anymore. They actually forced us to move on from it because the editor just doesn't care to look for it or even recognize it (when selected in the dropdown) anymore.

    I have the stuff linked now (as shown in the Help->About dialog), but my project files are showing up in VS 2015 Pro as not compatible and it generates one of those UpgradeLog.html files when I open the solution in the editor. I also am not seeing the options for the Unity solution viewer in VS 2015. I had installed the VS2015 tools, but it isn't showing in my installed plugin list.

    Are you seeing this as well? Also, do you have any tips or a link on how to maybe just create the solution from within VS?

    Thanks so much for taking the time to respond and help. I really appreciate it. This has probably been the roughest point release of Unity I've ever dealt with.

    Update: Well, it's not showing as installed now, but I was able to uninstall VS tools for 2015, reinstall them, deleted my project's solution files, restarted my computer, and then tried Open C# Project and the solution files are fine now. Still no plugin being shown as installed, but the Intellisense I was missing before is working now. Let me know if you're VS Tools is actually showing as installed on your VS2015 Pro
     
    Last edited: Sep 10, 2015
  11. bigbadtrumpet125

    bigbadtrumpet125

    Joined:
    Apr 1, 2013
    Posts:
    18
  12. chrismarch

    chrismarch

    Joined:
    Jul 24, 2013
    Posts:
    318
    Did you (or anyone) get their project to load in VS2013 and Unity 5.2 (and VSTU 2.1 for 2013), or are you writing about VS2015?
     
  13. chrismarch

    chrismarch

    Joined:
    Jul 24, 2013
    Posts:
    318
    I can now open our project and debug it with Unity Editor 5.2 64-bit for Windows and VSTU 2.1 for 2013. Unity Editor 5.2 seems to lock up more than 5.1.1f1, but at least I can make progress testing 5.2, without upgrading to VS2015 right now.

    Here's what I did:
    1. Uninstalled older VSTU
    2. Deleted UnityVS from project
    3. Confirmed that Edit>Preferences>External Tools External Script Editor is Visual Studio 2013
    4. Closed Unity Editor and Visual Studio
    5. Installed VSTU 2.1 for VS2013
    6. Deleted all VS related files from our project, like project files and user prefernce files, except our solution file (which has some external projects).
    7. Made our solution file writable
    8. Started Unity Editor and confirmed that Help>About has the line about VSTU in the lower left
    9. Assets>Open C# Project
    10. In VS2013, Debug>Attach Unity Debugger
    11. set a breakpoint in VS2013
    12. pressed play in Unity Editor, and then hit my bp in VS2013
     
    zerik and BinaryBanana like this.
  14. diekeure

    diekeure

    Joined:
    Jan 25, 2013
    Posts:
    219
    Just to be sure, do the people that can't run VS have resharper too?
     
  15. Hodgson_SDAS

    Hodgson_SDAS

    Joined:
    Apr 30, 2015
    Posts:
    123
    I think it may be related to Resharper as well
     
  16. bigbadtrumpet125

    bigbadtrumpet125

    Joined:
    Apr 1, 2013
    Posts:
    18
    I got it to work with 2013
     
    chrismarch likes this.
  17. Libor

    Libor

    Joined:
    Apr 24, 2014
    Posts:
    2
    Unity 5.2.0p1
    VS2013 - VSTU 2.1
    I did every steps and still debug doesn't work!
    It' s really bad situation!!!
    Everything was ok in older Unity version.
     
  18. Libor

    Libor

    Joined:
    Apr 24, 2014
    Posts:
    2
    I finally solved this big trouble.
    1.1 Uninstall VSTU
    1.2 uninstall Visual Studio 2013
    1.3 restart PC
    1.4 install Visual Studio 2013
    2. from this point I have the same steps like chrismarch in previous post

    I'm not sure, but the problem is probably in Visual Studio 2013 UPDATE 5
     
  19. diekeure

    diekeure

    Joined:
    Jan 25, 2013
    Posts:
    219
    I'll try to describe what happens for me (with 5.2.1, VS 2013 and latest Resharper 8.x):

    I start VS via Assets -> Open C# project



    Then this appears (good):



    A bit later this appears:



    And other messages. I believe it is output from resharper, I don't have this output with 4.6.8.
    A bit later I get this, so resharper is up and running for sure:



    And then nothing happens anymore. If I use process explorer I see that visuals studio is started en busy (but not a child process of Unity as it was before):



    But it's impossible to bring the window up:



    I'd love to have a working Visual Studio again, so if I can help with this issue, please tell me what extra info you need from me.

    Thanks,
    Alex
     
  20. tw3sth

    tw3sth

    Joined:
    Mar 2, 2015
    Posts:
    4
    In my case Unity 5.2 now launches MonoDevelop no matter what I do.

    Versions: Unity 5.2.1f1, Visual Studio Ultimate 2013 Update 4

    I used almost exactly the same procedure as chrismarch described:
    1. Uninstalled older VSTU
    2. Deleted UnityVS from project
    3. Confirmed that Edit>Preferences>External Tools External Script Editor is Visual Studio 2013
    4. Closed Unity Editor and Visual Studio
    5. Installed VSTU 2.1 for VS2013
    6. Deleted all VS related files from the project
    7. Started Unity Editor and confirmed that Help>About has the line about VSTU 2.1 in the lower left
    8. Assets>Open C# Project
    Then the "Opening Visual Studio" popup box appears, but MonoDevelop is launched instead of Visual Studio and the popup box just hangs. I tried reinstalling VSTU several times, booting my computer...nothing solves it.
     
  21. tw3sth

    tw3sth

    Joined:
    Mar 2, 2015
    Posts:
    4
    I tried reinstalling both Unity 5.2 (this time without MonoDevelop) and Visual Studio 2013. Now Unity opens a Windows File Explore instead of Visual Studio 2013. I have to conclude that VS integration in 5.2 is totally broken.
     
  22. tw3sth

    tw3sth

    Joined:
    Mar 2, 2015
    Posts:
    4
    Ok - I fixed it. I upgraded Visual Studio 2013 to Update 5 and ran Unity 5.2 as administrator.
     
  23. diekeure

    diekeure

    Joined:
    Jan 25, 2013
    Posts:
    219
    This was fixed for me in 5.2.1p3, many thanks!
     
  24. TokyoDan

    TokyoDan

    Joined:
    Jun 16, 2012
    Posts:
    1,080
    I just installed the latest version of Unity (5.2.2f1 Personal) on my NEW Windows 10 machine. In the installer it showed that both Visual Studio Community 2015 and UnityVS would be installed (I selected everything in that window that asks what you want to install). So after Unity finished installing. I ran it and loaded the example project and opened a C# file, but it opened MonoDevelop instead of Visual Studio. I looked in the Preference and External Script Editor is set to 'Internal'. But when I browse to find UnityVS or Visual Studio I can't find either of them anywhere.