Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. We are looking for your feedback about Templates! Tell us about your experiences by taking our survey.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  4. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Visual Artifacts on Terrain and Cubes on the Sunny Side

Discussion in 'AR/VR (XR) Discussion' started by tgraupmann, Mar 5, 2016.

  1. tgraupmann

    tgraupmann

    Joined:
    Sep 14, 2007
    Posts:
    828
    I ran into a visual problem with Gear VR that didn't happen with the Oculus Rift DK1. I'm running Gear VR on a Samsung Note 5. I have an OUYA controller connected over bluetooth.

    Unity 5.3.3

    The demo first person scene appears correctly.



    There's some odd visual artifacts appearing on the terrain and cubes on the sunny side.


    I'm not sure if it's a scale issue. There's nothing special about the material which is just the default diffuse color.


    I put more details about the setup in a blog post.
    http://tagenigma.com/blog/2016/03/04/samsung-gear-vr-demo/

    The material is `default-material` with the `standard` shader.

    The scale of the cube with the artifacts is 13x12x20.

    The sample FirstPersonScene has a Box_Room with a scale of 1x1x1. With the shader of Mobile/Diffuse. I'll try that.

    Same issue using the `Mobile/Diffuse` shader.

     
    Last edited: Mar 5, 2016
  2. tgraupmann

    tgraupmann

    Joined:
    Sep 14, 2007
    Posts:
    828
    Looks like it's an issue with a directional light.



    When I switched to a baked area light, the artifacts went away.

    The Gear VR is a 2K display, but you really can see the aliasing. Maybe we need 5K VR headsets.
     
  3. tgraupmann

    tgraupmann

    Joined:
    Sep 14, 2007
    Posts:
    828
    Tweaking the Point light to mixed mode reproduces the lighting more closely with the desktop version.



    I used Type: Point, Baking: Mixed, Draw Halo: true, and Range: 395.7.



    I am seeing a ton of light and shadow clip issues in the editor and on the Note 5. These are just planes and cubes after all.

    The editor preview just seems to be the shadows have a far range, is there a project setting to adjust that?

    And then on the Note 5, as I walked into shadow areas, the shadows kept appearing or disappearing depending on the direction that I was looking.

    I have a reproducible project if the shadow guy needs it.
     
  4. stevenbrent

    stevenbrent

    Joined:
    Nov 22, 2015
    Posts:
    25
unityunity