Search Unity

  1. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  2. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Participate with students all over the world and build projects to teach people. Join now!
    Dismiss Notice
  5. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Virtual cameras "Body" keeps resetting to Do Nothing?

Discussion in 'Cinemachine' started by Daniel__Vernon, Oct 10, 2018.

  1. Daniel__Vernon

    Daniel__Vernon

    Joined:
    May 29, 2016
    Posts:
    1
    I am using a virtual camera to follow a player in a 2D environment and using the "Body" set to "Transposer". Randomly every now and then the Body will change back to "Do Nothing" and discards my original Transposer settings when I'm in no way editing the camera or any parents/ children of it.

    I have been working around this by using a preset that has all of my saved settings and I would revert it back to whenever my virtual camera resets itself (Which happens a lot).

    However I have just ran into the problem of Not only my Virtual Cameras Body resetting to "Do Nothing" but the Preset I created ages ago also reset its "Body" to "Do Nothing". I really wish I knew why this was happening and if there was something I could do to change it?


    Add comment
     
  2. Gregoryl

    Gregoryl

    Unity Technologies

    Joined:
    Dec 22, 2016
    Posts:
    1,815
    Virtual cameras don't support presets. What if you used a prefab instead?