Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. The 2023.1 beta is now available for testing. To find out what's new, have a look at our 2023.1 feature highlights.
    Dismiss Notice

Viewport lag with tree editor (and other)

Discussion in '5.4 Beta' started by pointcache, Apr 27, 2016.

  1. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    570

    Is this normal?
    happens on b14 b15 100%

    im on
     
  2. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    570
    driver 364.72
     
  3. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    570
    Also lags in other places where gizmos are displayed (cant recall which one exactly but it is there)
     
  4. pvloon

    pvloon

    Joined:
    Oct 5, 2011
    Posts:
    591
    Have had similair issues, profiling showed the gizmos functions drawing a LOT of times (1000s and 1000s for simple stuff). If I have some time I'll make a proper bug report
     
  5. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    570
    I dont think this needs any report, just start making a tree in empty project and there it is.
     
  6. pvloon

    pvloon

    Joined:
    Oct 5, 2011
    Posts:
    591
    In an ideal world yes, but knowing Unity the first reply to this thread will be "bug nr. please?" ;)
     
  7. pointcache

    pointcache

    Joined:
    Sep 22, 2012
    Posts:
    570
    Ok this is not actually a problem with the Gizmos!
    This same exactl lag happens when you rotate preview of the model !
    So its actually a general perofrmance degradation in viewports.