Search Unity

Video Video Player issue after updating from standard to URP

Discussion in 'Audio & Video' started by SpiderJones, Nov 2, 2023.

  1. SpiderJones

    SpiderJones

    Joined:
    Mar 29, 2014
    Posts:
    245
    Hi,

    I have a video player that downloads and plays videos from my server. It worked fine before I updated the project to URP. Now at the start of the video artifacts for less than a second are shown, then plays fine. But when I tap my close button that loads another scene, the scene hangs with unresponsive buttons BUT some of the buttons in the new scene that's loaded are active. In the new scene that's loaded there is a button to take a photo, and when I tap in the area of this button it takes a photo and then the video player scene goes away. It seems like the video player scene is still stuck in the renderer and rendering on top of the new scene. Is this possible? Maybe that's not what is actually happening. But again, the scene with the video player get's stuck. When I try to go to the next scene the bellow messages is printed to Logcat:

    Code (CSharp):
    1. 11437 11564 Error native E0000 00:00:1698891377.038811   11564 scheduler.cc:277] INTERNAL: RET_CHECK failure (third_party/mediapipe/framework/scheduler.cc:277) state_ != STATE_NOT_STARTED (0 vs. 0)
    2.  
    I'm using Unity 2022.3.10f1. And the project is using ARFoundation 5.0.7. The scene with the video player is not using ARFoundation.

    I'm testing on Android.

    Any tips?