Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Resolved Video player don't working on IOS

Discussion in 'Audio & Video' started by RafaelGomes00, Mar 9, 2022.

  1. RafaelGomes00

    RafaelGomes00

    Joined:
    Aug 13, 2020
    Posts:
    73
    Hello, i'm having a problem with the video player component in a mobile game that i'm working on, basically the problem is that the video from the video player simply don't play, on Android it works just fine, but on IOS it doesn't, i tried Changing the encoding to H.264 on the importing settings, and the video appeared, but with 1 or 2 fps. Any solution to that?

    Info:
    Format: .mp4
    Codec: Auto (Don't work) / H.264 (Work at 2 fps)
    Unity Version: 2020.3.30f1 (LTS)
    Video size: 3MB

    Bonus question: I have some videos that are downloaded from the internet in runtime using Unity.WebRequest, and those videos that i download works just fine, so here's my question: Why a video that i downloaded from a url works, but a video that is imported on the game folder don't?
     
  2. The_Island

    The_Island

    Unity Technologies

    Joined:
    Jun 1, 2021
    Posts:
    502
    Are you saying that the same video when downloaded using Unity.WebRequest works but not when imported? It clearly seems to be a bug if the same code works on android but not on iOS. Can you open a bug report? We will investigate what is happening. If you can, can you try on another iOS phone and see if the same issue happens? Maybe the issue is only happening on this specific device so make sure to specify the model in the bug report.
     
  3. RafaelGomes00

    RafaelGomes00

    Joined:
    Aug 13, 2020
    Posts:
    73
    Sorry for the late response, but i have to do more tests with it, because it seems that the info that it don't work only in IOS may be wrong, and there could be an issue with the video, or some configuration that is wrong, and I'm not having time to test it properly, because I'm having other issue with shaders that don't render, might as well create another thread for this problem.
     
  4. RafaelGomes00

    RafaelGomes00

    Joined:
    Aug 13, 2020
    Posts:
    73
    I managed to find that the problem is indeed on the video, testing with the video that I use in another part of the game, it works.

    I'm gonna mark this thread as "Resolved" as soon that, the problem was found, and I will work to fix the video :)
     
  5. ben-hirsh-gripable

    ben-hirsh-gripable

    Joined:
    Jan 22, 2019
    Posts:
    7
    did you ever find out why the video was not working in iOS?
     
  6. RafaelGomes00

    RafaelGomes00

    Joined:
    Aug 13, 2020
    Posts:
    73
    It was a problem on the video itself. I think that was something with the encoding format that the video was exported.