Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

VFX not playing when the camera is not looking at it

Discussion in 'Visual Effect Graph' started by LiableDuke, Sep 29, 2020.

  1. LiableDuke

    LiableDuke

    Joined:
    Feb 8, 2018
    Posts:
    32
    like the title says the effect does not play until the camera looks at it. I get that this is useful for some particles (like in the environment) but not to much for a muzzle flash. how do I fix this?
     
  2. Olmi

    Olmi

    Joined:
    Nov 29, 2012
    Posts:
    1,518
    Hi @LiableDuke,
    Have tried to adjust the Culling Flags for the VFX? Select the asset in Project, then you should see settings for the asset in Inspector. There's "Culling Flags" field, try select "Always recompute and simulate". There's also settings for pre-warming. Maybe this helps, not sure if it works as I can't try now.
     
    LiableDuke likes this.
  3. LiableDuke

    LiableDuke

    Joined:
    Feb 8, 2018
    Posts:
    32
    yes that worked thanks!
     
    Last edited: Oct 1, 2020