Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

VFX Graph soft particle doesnt receive shadows

Discussion in 'Graphics Experimental Previews' started by Cell-i-Zenit, Dec 27, 2019.

  1. Cell-i-Zenit

    Cell-i-Zenit

    Joined:
    Mar 11, 2016
    Posts:
    290
    Hi,

    so i have this here:

    https://imgur.com/mPwHJGN

    I would like to receive shadows on my soft particles.

    The VFX Graph has

    Transparency:0
    Rendering Layer Mask: LightLayer Default
    Light Probes: Off

    The Prefab has
    CastShadows On (but this doesnt work somehow?)
    Receive Shadows: true (this is what i want to have!)
    Render Priority: 0
    Rendering Layer Mask: 1

    What do i need to do to make my particles receive shadows?

    thanks.


    EDIT: the output node of my VFX Graph is Ouput Particle Cube with Soft Particle set to 2

    EDIT2: i found that when i do lit mesh .. i can select a cube as a mesh and do the soft particle settings. But this soft particle setting is missing in the normal "lit particle cube" output node...

    I "lose" ~ 15 fps just by switching the node :(
     
    Last edited: Dec 27, 2019