Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question VFX Graph Skinned Mesh only visible from a specific angle

Discussion in 'Visual Effect Graph' started by ItsPerona, May 17, 2024.

  1. ItsPerona

    ItsPerona

    Joined:
    Dec 29, 2022
    Posts:
    4
    I am trying to use Skinned Mesh from VFX Graph to make a silhouette of the character, the problem is that the VFX can only be seen if you look at the character from a certain angle, when you move slightly it stops being seen and when you return to the angle it is seen again .

    I am using Unity 2021.3.33f, and yes, i have Read/Write enabled

    An angle where the VFX is seen:
    1.png


    I move slightly, the VFX disappears:
    2.png


    My current VFX Graph:
    3.png
     
  2. PaulDemeulenaere

    PaulDemeulenaere

    Unity Technologies

    Joined:
    Sep 29, 2016
    Posts:
    159
    Hello,
    Your VFX is using in local space and seems to be located at the foot of the character.

    Can you uncollapse the current bound settings ?
    upload_2024-5-17_8-20-0.png
    I'm suspecting the bounds being too small and leading the VFX to be culled.

    Also, you have to be aware the skinned mesh sampling relies on the Update When Offscreen settings of the SkinnedMeshRenderer but it doesn't seems to be your issue here, it would have switched the mesh to a T-Pose.
     
  3. ItsPerona

    ItsPerona

    Joined:
    Dec 29, 2022
    Posts:
    4
    I have activated updateWhenOffscreen just in case, I have also moved the transform from root to hips but now the vfx is higher than it should be. I see that changing to "Automatic" mode is visible at all times and in manual the bounds are placed very far from where the character really is.

    4.png
     
  4. ItsPerona

    ItsPerona

    Joined:
    Dec 29, 2022
    Posts:
    4
    I'm going to assume that auto mode and positioning the vfx at the character's feet is correct. Otherwise the VFX bounds are placed away from the character and the particles are placed higher than they should be.
     
  5. PaulDemeulenaere

    PaulDemeulenaere

    Unity Technologies

    Joined:
    Sep 29, 2016
    Posts:
    159
    Indeed, you can use auto mode bounds to simplify the authoring.

    Alternatively, I assumed the root node of your skinned mesh is probably the feet and your setup is based on unit corresponding to 1 meters, having a box of 1 meter diameters seems too small to encapsulate your particles placement. It looks like having a taller bound would be enough:
    upload_2024-5-23_9-30-35.png

    You can also change the space of the system from Local to World and manually control particles placement without relying on parent system position. The bounds can be expressed in world space (the "L" next to "Bounds" is a clickable element).

    By the way, the transform handling for Skinned Mesh Renderer has been improved in 2022.2.a14, see this post.