Search Unity

  1. Unity Asset Manager is now available in public beta. Try it out now and join the conversation here in the forums.
    Dismiss Notice
  2. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  3. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

[VFX Graph] Particles with emission not affecting bloom

Discussion in 'Graphics Experimental Previews' started by keenanwoodall, May 8, 2019.

  1. keenanwoodall

    keenanwoodall

    Joined:
    May 30, 2014
    Posts:
    598
    I'm working on a particle system and would like the particles to glow when their color gets bright enough. I can't seem to figure out how to make it work.

    Sanity Check: Here's a cube with a standard emissive material applied in my scene.
    upload_2019-5-7_23-26-50.png

    Here's my output settings:
    upload_2019-5-7_23-31-41.png upload_2019-5-7_23-27-24.png

    And this is what it looks like:
    upload_2019-5-7_23-33-7.png

    As you can see there is no bloom. Any ideas as to what I'm doing wrong?
     
  2. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    34
    Hey, I think it has to do with the new Unity version, because I have turned it the emission up to 10, and there's only a tiny amount of bloom. It used to work for me, so I'm guessing it's the new version...
     
    Last edited: May 29, 2019
  3. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    34
    Fixed it, I turned on HDR and chose the Deferred rendering path, and now it is super bright.
     
  4. keenanwoodall

    keenanwoodall

    Joined:
    May 30, 2014
    Posts:
    598
    Where do you see HDR option? I thought it was forced on when using HDRP because there isn't a toggle on the camera's inspector for it anymore.
     
  5. LawrenceDev

    LawrenceDev

    Joined:
    Aug 20, 2015
    Posts:
    34
    I toggled it on in the camera's inspector, so if it doesn't show, I don't know a solution.