Search Unity

very slow import after disabling crunch compression

Discussion in 'General Discussion' started by school-dev, Mar 6, 2019.

  1. school-dev

    school-dev

    Joined:
    Oct 2, 2017
    Posts:
    1
    I found the solution but was quite surprised.

    1) Had textures with normal quality (compressed)
    2) Enabled crunch compression and set quality to 100
    3) Disabled crunch compression and my editor started endlessly importing textures.

    I am using unity 2018.2.6f1.

    So the solution was to turn on crunch to display slider, set slider to 50 and turn crunch off again.
    I guess the slider overrides the field Compression:NormalQuality and set it to best quality that is why importing was not finishing.

    Anyway it looks like a bug.