Search Unity

  1. Unity 2020.2 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Very large build size: "Built-in Mesh: Combined Mesh (root: scene)"

Discussion in 'Editor & General Support' started by the_mr_matt, Nov 20, 2020.

  1. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    118
    I'm getting very large build sizes. Upon inspection in the editor log I found these stats:

    Code (CSharp):
    1. Textures               365.2 mb     4.3%
    2. Meshes                 6.2 gb     75.1%
    3. Animations             565.3 kb     0.0%
    4. Sounds                 149.9 mb     1.8%
    5. Shaders                7.0 mb     0.1%
    6. Other Assets           16.0 mb     0.2%
    7. Levels                 1.5 gb     18.2%
    8. Scripts                11.6 mb     0.1%
    9. Included DLLs          13.5 mb     0.2%
    10. File headers           961.4 kb     0.0%
    11. Total User Assets      8.3 gb     100.0%
    12. Complete build size    8.3 gb
    Following that were probably several hundred if not thousands of "Built-in Mesh: Combined Mesh (root: scene)".

    I believe this comes from static batching. Some of my scenes have many thousands of trees. I tried a build with static batching enabled on the trees. Mesh size was 7.4Gb. Disabling static batching on those trees reduced the mesh size to 6.2Gb. Now for obvious reasons I don't want to disable static batching on everything. Is there any way I can reduce the size of these combined meshes?
     
  2. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    118
  3. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    118
  4. gabrielosinaga

    gabrielosinaga

    Joined:
    Mar 22, 2020
    Posts:
    1
    Did you found a solution? i have a lot of this objects and i want to reduce the size
    upload_2021-1-14_12-8-14.png
     
  5. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    118
    No solution, and as you can see, not a lot of attention in this thread :'((
     
  6. gargaroots

    gargaroots

    Joined:
    Dec 8, 2016
    Posts:
    2
    Hi!, You probably found the solution already, but I'll type it here so others, like me, can find it faster.

    These Combined Meshes are created when you have "Static Batching" enabled in your Player/Other Settings.
    This is useful for performance reasons, but yeah your build will be huge.

    I went from 488mb to 80mb by just disabling it, and didn't notice performance degradation.
     
unityunity