Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Bug Validator issues with uploading Vulkan build via Oculus Platform Tool or Quest Dev Hub

Discussion in 'VR' started by reddo, Jun 18, 2023.

  1. reddo

    reddo

    Joined:
    Jul 1, 2015
    Posts:
    39
    When trying to upload a Vulkan only Quest app via the Meta Quest Developer Hub or the Oculus Platform Tool in Unity it's coming up with validation errors:

    GLES_VERSION_NOT_SPECIFIED
    GLES version not specified (android:glEsVersion in AndroidManifest.xml). GLES version of 2.0 or greater should be used.


    and

    This app contains both 32-bit (armeabi-v7a) and 64-bit (arm64-v8a) libraries. This consumes extra storage and increases download times. Consider updating your build to target 64-bit only.

    The issue being that it uses Vulkan only and haven't had issues uploading with a Vulkan only build before.
    Also, only ARM64 was checked in the player settings in Unity when built and didn't get the validation error on previous upload.

    Using Unity 2021.3.26 and Oculus Integration v53
     
  2. glenneroo

    glenneroo

    Joined:
    Oct 27, 2016
    Posts:
    228
    I just had this error a few weeks ago after updating from v49 to v54. I unfortunately don't remember the solution but after trying a lot of ideas, out of desperation, I deselected arm64 (and maybe 32bit?) then reselected only arm64t, saving in-between deselecting/selecting (maybe also restarting Unity in-between?). I'm 95% positive this is what fixed it. Sorry I can't offer more help, I should have checked git and researched the solution.
     
  3. reddo

    reddo

    Joined:
    Jul 1, 2015
    Posts:
    39
    Thanks for the tip. I tried selecting and deselecting arm64 and 32bit then restarting. The build still got the same errors.
    I got around it by adding GLES to the player settings under Vulkan, rebuilt, and this one passed validation.
    Not ideal but it worked.
     
  4. meangpu

    meangpu

    Joined:
    Nov 15, 2019
    Posts:
    1
    I encountered the same problem today. Three days ago, I successfully uploaded an .apk file through MetaQuestDeveloper. However, when I attempted to upload it today, I encountered this error and not able to push update to my application.
    "This app contains both 32-bit (armeabi-v7a) and 64-bit (arm64-v8a) libraries. This consumes extra storage and increases download times. Consider updating your build to target 64-bit only."

    I use unity 2022.2.17f1 with UnityXR Interaction toolkit
    I orinally use GLES with no vulkan

    I Have tried
    - I am certainly have already select only ARM64 and not select ARMv7
    - upgrade unity to 2022.3.2f1LTS and rebuid the project
    - try install oculus integration package and rebuild the project
    - use TargetArchitectures/SplitAPKs by target architecture to seperate .apk out into 2 file and upload the x64 one
    - upload_2023-6-21_0-51-39.png
    - upload_2023-6-21_0-50-16.png
    None of the method above that I tried work

    I can confirm that I did not make any changes to the player settings or export settings. Every setting related to building the project remains the same as last week. The problem only appeared today.
     
    Last edited: Jun 20, 2023
  5. KayH

    KayH

    Joined:
    Jan 6, 2017
    Posts:
    107
    Same problem. I identified these files in my decompiled APK file:
    armeabi02.jpg armeabi01.jpg
    You should check your APK for what 32-bit libraries are actually present.

    I asked on the Android forum if anyone recognizes the files in my APK:

    https://forum.unity.com/threads/ori...uble-conversion-libxplat_perflogger_.1458862/