Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Using your own model with third person controller == consistent fail

Discussion in 'Animation' started by darrenval, Mar 2, 2014.

  1. darrenval


    Mar 2, 2014
    I'm a newbie to Unity (not to writing games or CG) but I'm really struggling to get animation and movement of a character model working with a third person controller, just to test it walking around/jump/idle etc.

    I know how to do it, i.e drag the prefab 3rd person construction worker into your scene and delete his contents and drag your character's contents onto his top-level CC null. Then you set/ label/loop your animation clips in the importer. Got that. Fine.

    You then go back to the CC null and set the appropriate animations you've defined to replace the ones that were referencing the construction workers'. OK go that too.

    I've even got you need to set the animation type to 'legacy'. Not sure why it's called legacy, or why it needs to be set like this... but anyway.

    However after setting animation to legacy.......... everything breaks down.

    The idle I have set (or any other animation clip I choose) will play, but the character now just remains stuck somewhere in the middle of the floor when the game is run.

    It doesn't matter how you alter the collider capsule around the character, the character just stays there half way through whatever the floor geometry is (have tried with various including a plane to test), i.e it *doesn’t* fall completely through and carry on falling.

    The character doesn't respond to input in this state and will not move (it did before setting animation to legacy but then wouldn't display animation), nor will it change animation (i.e to a walk) from whatever the first one is being played is.

    I basically give up. I have no idea why this is so difficult, the only thought I have had is there is something persistently wrong with the FBX files I am creating. Or something is gravely missing from every tutorial I have read on this so far. Or is there is a major bug in this version of Unity preventing this ?

    I have tried with several different character models which I have set up and animated with simple walk cycles and idles etc.

    I am exporting from the latest Lightwave, using I believe the latest version of the FBX exporter in Lightwave and running Unity free version 4.3.2f1 on the Mac.