Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Using 5.5.2p3+ 5.4.5p1 to avoid rejection from the TIZEN store

Discussion in 'Tizen' started by sukwon-suh, Apr 7, 2017.

  1. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Dear Unity developers,
    Please refer the email below from TIZEN seller office.





    Dear Developers,

    Thank you for using the Tizen Store Seller Office.

    We reviewed compatibility of the UNITY app after TIZEN version upgrade and found some potential problems related to compatibility.
    This kind of issue can occur in an app which doesn't use the latest UNITY version.
    If you do not upgrade your application on the store, it will not run on the latest TIZEN version.

    So, we prepared a new UNITY engine and now we'd like to share it with you.
    Please check our guide and apply it if you think it's necessary for your app

    App Name
    - UNITY Application

    Problem
    - Application is getting closed automatically after lock-unlock phone
    - Application has stopped unexpectedly, while quitting the Game
    - Exception observed while opening Apps

    Cause
    - UNITY potential problem

    Guide : Make new package with the latest UNITY engine.
    - 5.4.5p1 : 22 March 2017 (Tizen 2.3+)
    - 5.5.2p3 : 15 March 2017 (Tizen 2.4+)
    - 5.6.0p1 : 18 April 2017 (Tizen 2.4+)
    https://unity3d.com/unity/qa/patch-releases


    Remark
    Unity 5.4.x (e.g. 5.4.5p1) support Tizen 2.3 above.
    Unity 5.5.x and 5.6.x does NOT support Tizen 2.3. Some Z1 device is using Tizen 2.3.
    For more details, please refer the site as below.
    http://www.tizenincentive.com/resources.do

    If you have any further inquiries, please contact us.
    Tizen Store Seller Office will continue to be dedicated to providing better services to our valued customers.
    - Native/Unity Application: tizen.native@samsung.com
    * Seller Office: Seller Office > Support > My Q&A

    Thank you
    Tizen Store Seller Office Team

    This is an automatically generated email. Please do not reply.
    Copyright © 2017 Tizen Store All rights reserved.
    Terms and Conditions| Privacy Policy
     
    Last edited: Apr 27, 2017
  2. OnurYIL

    OnurYIL

    Joined:
    Nov 4, 2013
    Posts:
    140
    I did not get such e-mail.

    Also, I have submitted and approved a game 4 days ago, using Unity 5.4.1.
     
  3. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Dear OnurYIL.
    I'm Sukwon Suh in TIZEN R&D team.

    This is potential bug and compatibility issue when upgrading TIZEN version.
    If you are using 5.4.1 Unity version, your app has 2 issues.

    - Application has stopped unexpectedly, while quitting the Game
    > You can see a little hanging and last image when quiting the game.

    - Exception observed while opening Apps
    > You cannot launch app immediately after reboot the phone. You have to wait 1 minute to launch Unity application.

    email will be delivered at next week(I expect it on Monday)
    Thank you.
     
    Last edited: Apr 7, 2017
  4. OnurYIL

    OnurYIL

    Joined:
    Nov 4, 2013
    Posts:
    140
    But latest Unity versions doesn't support 2.3? What about that?

    Edit: I just saw this "- 5.4.5p1 : 22 March 2017 (Tizen 2.3+)"

    Does this mean I have to use 5.4.5p1 in order to have support for all Tizen devices?
     
  5. skaljac

    skaljac

    Joined:
    Apr 9, 2015
    Posts:
    33
    Thank you for your quick update!
     
  6. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Exactly you are right!
     
  7. oriolmanya

    oriolmanya

    Joined:
    Jul 4, 2012
    Posts:
    36
    Hi sukwon-su,

    I've developed my game under Unity 5.5.2, and I see several patch versions for 5.5.X.

    Is it preferable that I use Patch 5.5.2p4 or Patch 5.5.3p1?

    Which one is more reliable?

    Thanks in advance!
     
  8. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    I did not test 5.5.3p1 yet. I'll let you know result soon.
     
    Last edited: Apr 12, 2017
  9. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Hello,
    5.5.3p1 is fine. I recommend the latest version (5.5.3p1).
    Thank you!
     
    milkymomo and oriolmanya like this.
  10. OnurYIL

    OnurYIL

    Joined:
    Nov 4, 2013
    Posts:
    140
    @sukwon-suh
    I have updated my game which is already on the Tizen Store. I installed the 5.4.5p1 version, opened my unutoched project with this version, created a TPK, tested it on RTL devices first, then uploaded to the Store. The next day, they rejected the update for the reasons below:



    The game works fine on RTL devices, zero problem. I do not have any other way to test this since no devices outside of India.

    Edit: Inside the core_hash.txt file: "Hash exist and hash not match. - shared/res/data/Managed/mono/2.0/mscorlib.dll"
     
    Last edited: Apr 14, 2017
    milkymomo likes this.
  11. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Dear OnurYIL,

    It looks you re-registered your app again after rejection, and currently your app is now on valid progress(integraty test passed).
    Generally, integrity test failure occur when you modified files on your package manually.
    Did you modify some files manually after packaging?
     
    OnurYIL and milkymomo like this.
  12. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    5.6.0p1 available now.
     
    milkymomo likes this.
  13. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    This is available unity versions for Tizen.
    upload_2017-4-27_10-13-29.png
     
    milkymomo likes this.
  14. Jonny-Roy

    Jonny-Roy

    Joined:
    May 29, 2013
    Posts:
    660
    Hi Sukwon-suh,

    I used to have a game in the Wearable store called Ducker which was built with Unity, but they changed some policies which means we can no longer use Unity to build for Wearables, do you know if there is any way around this?

    Thanks,

    Jon
     
  15. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Dear Jonny,
    Are you rejected from TIZEN store as reason below?
    Undocumented APIs is detected (white list).
     
  16. Maulwurfmann

    Maulwurfmann

    Joined:
    Mar 11, 2014
    Posts:
    366
    I have submitted a game with the latest Unity Version (5.6.0p3), but certification failed -> Application can not be executed.
    But i have tested it with Remote Lab and it works fine there, how can this be?

    I have also submitted a few other games and now i fear they will also fail in certification, but they all worked fine with Remote Lab and Emulator :(

    I have attached the dump log.
     

    Attached Files:

  17. Maulwurfmann

    Maulwurfmann

    Joined:
    Mar 11, 2014
    Posts:
    366
    I have now looked a bit into the log and think is the part where the app fails to launch:
    Apparently the info file is missing and it does not have a launch condition??
    Could somenone please tell me how i can fix this?

    Many thanks in advance!
     
  18. aaangga

    aaangga

    Joined:
    Apr 4, 2017
    Posts:
    1
    Hi Sukwon-Suh,

    I have submitted a game with the latest Unity Version (5.6.0p3), but still got the issue.

    Should I use 5.6.0p1 as you mention above? (sukwon-suh : 5.6.0p1 available now.)

    Thanks,

    upload_2017-5-6_15-45-51.png
     
  19. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    @aaangga
    5.6.0p3 is fine.
    I think you used 5.6.0f3 version then rejected.
    Thanks
     
  20. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    Did you solve problems?
     
  21. Maulwurfmann

    Maulwurfmann

    Joined:
    Mar 11, 2014
    Posts:
    366
    My other games i submitted worked fine, so i made some minor changes in player settings and submitted it again, but it hasn`t been validated yet.
     
  22. TheKing009

    TheKing009

    Joined:
    Nov 21, 2016
    Posts:
    10
    Hey. I deployed a game for tizen, first using 5.5.1 and then using 5.4.5 but still got the same errors-
    Undocumented Api detected
    Application crashed while quitting
    Application quits when phone locked and unlocked
    Exception observated while opening apps.


    Please help
     
  23. Maulwurfmann

    Maulwurfmann

    Joined:
    Mar 11, 2014
    Posts:
    366
    It has now been approved. Thanks.
     
  24. maxinteractive

    maxinteractive

    Joined:
    Nov 24, 2016
    Posts:
    44
    Hi sukwon-suh,

    Need some advice and helps,
    Using unity 5.6.1p1, re-registered app after rejection, and came back with integrity test failure.
    After testing on a Z3, package and upload to tizenstore. Could it be transmission errors ?

    First time, encounter this error. How do i fix it ? rebuild & resubmit ?

    4_core_hash.txt :
    Hash exist and hash not match. - shared/res/data/Managed/UnityEngine.dll

    thank you!
     
    Last edited: Jun 5, 2017
  25. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    @maxinteractive
    Would you please update your version information and then re-register it again?
    Sometime, integrity failure occur when you register your app without version changes.
     
  26. sukwon-suh

    sukwon-suh

    Joined:
    Mar 31, 2015
    Posts:
    81
    @maxinteractive
    I checked this issue with TIZEN STORE team, there is a problem and now it fixed.
    I apologize for the inconvenience.
     
  27. maxinteractive

    maxinteractive

    Joined:
    Nov 24, 2016
    Posts:
    44
    Thank you for the help!

    Ok, changed to version 1.0.1 and upgrade to unity 5.6.1p2.
    Resubmitted to tizenstore and hope it can pass verifications, finger crossed!
     
  28. vijay-goswami

    vijay-goswami

    Joined:
    May 17, 2017
    Posts:
    7
    @sukwon-suh

    I have submitted a game using unity 5.4 but it rejected because of unity version.

    I am using Tizen IAP package (https://www.assetstore.unity3d.com/en/#!/content/40219) for InApp in my game .It works on Unity 5.4 but now I upgraded my game to unity 5.6 and this IAP package is not working for me.

    It gives this error :
    The type or namespace name `Tizen' could not be found. Are you missing an assembly reference?


    Is it working for you?
    Should I do any changes to make it working?
     
    Last edited: Aug 17, 2017