Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

URP running on the Oculus quest. Scene is much brighter than in editor.

Discussion in 'Universal Render Pipeline' started by YuriyPopov, Nov 27, 2019.

  1. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    122
    I'm using URP 7.15 and Unity 2019.3.0b10. No matter what I do when the scene build to the Quest it apears brighter. Using the new Oculus Link that streams from the editor the scene looks nearly identical so it's not from the displays themselves. I have tried numerous settings, with lights and without, changing the format of the lightmaps, with post fx and without. No matter what I do the effect is still the same. Has anyone had this problem before?

    Edit: Hold on it might actually be the post process

    Edit 2 : Yes when the Post Processing on the camera is ticked off the scene is no longer brighter. Any ideas on how to fix this ?
     
    Last edited: Nov 27, 2019
  2. JasonMcEvoyFMR

    JasonMcEvoyFMR

    Joined:
    Apr 3, 2019
    Posts:
    2
    Same issue for me!!!
     
  3. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    122
    I'm still looking for a workaround. Have you made any progress ?
     
  4. aleksandrk

    aleksandrk

    Unity Technologies

    Joined:
    Jul 3, 2017
    Posts:
    1,246
    Hi!
    Can you please report a bug?
    Thanks!
     
  5. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    122
    I did. Case number : 1201377.
    I can pm you the fogbugz link too.
     
  6. aleksandrk

    aleksandrk

    Unity Technologies

    Joined:
    Jul 3, 2017
    Posts:
    1,246
    Great, thanks!
    No need, the bug ID is enough :)
     
  7. YuriyPopov

    YuriyPopov

    Joined:
    Sep 5, 2017
    Posts:
    122
    Keep me posted or if you need more info. This bug getting fixed or a workaround is very important to me. :)
     
    aleksandrk likes this.
  8. TashaSkyUpchurch

    TashaSkyUpchurch

    Joined:
    Jan 25, 2018
    Posts:
    10
    Changing the HDR mode to FP16 in Tier settings fixed this for me.
     
  9. JosephGovi_TechArtist

    JosephGovi_TechArtist

    Joined:
    Oct 3, 2018
    Posts:
    4
    Would like to add that I too experience this issue. Shown Here
     
  10. JosephGovi_TechArtist

    JosephGovi_TechArtist

    Joined:
    Oct 3, 2018
    Posts:
    4
    An update: I built for my android phone (pixel 2), and it displayed the correct lighting. So its something with the quest and/or unity. The tip from Yuri about changing HDR mode made no difference for me.
     
  11. Nico20003

    Nico20003

    Joined:
    Apr 4, 2014
    Posts:
    31
    Have anyone found a solution for this?
     
  12. Thomukas1

    Thomukas1

    Joined:
    Sep 29, 2014
    Posts:
    21
    Same issue!

    Edit: Updating URP to 7.2.1 fixed it, all good!
     
    Last edited: Mar 20, 2020
  13. ThomasZeng

    ThomasZeng

    Unity Technologies

    Joined:
    Jun 24, 2019
    Posts:
    16
unityunity