Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We are updating our Terms of Service for all Unity subscription plans, effective October 13, 2022, to create a more streamlined, user-friendly set of terms. Please review them here: unity.com/legal/terms-of-service.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Bug [URP] Depth texture doesn't work

Discussion in 'Universal Render Pipeline' started by yonatanab1, Aug 5, 2022.

  1. yonatanab1

    yonatanab1

    Joined:
    Sep 9, 2018
    Posts:
    40
    the "depth" field just doesn't work for me.

    I tried downloading urp asssets that use it such as water shader but they all return a smooth color.



    I also tried making water through an official tutorial but it's depth effect also doesn't work.

    (
    )

    I made sure to enable depth texture in the urp asset settings, and downloaded post processing and enabled it on the camera settings but nothing works for me.
    What should I do?
    I will share any needed details.

    [I am using Unity 2021.3.0f1 LTS + Latest Universal version available 12.1.6.]
     
  2. alexpana_

    alexpana_

    Joined:
    Mar 5, 2017
    Posts:
    10
    Add some cubes in the scene to overlap with the planes. The depth comes from other objects.
     
  3. Atilli

    Atilli

    Joined:
    Aug 31, 2022
    Posts:
    1
    Same here,I had to turn off depth and uncheck Quality HDR for the Universal RP-High Quality asset
     
unityunity