Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Resolved URP AR Camera keep selecting the URP HighFidelity as its Renderer.

Discussion in 'Universal Render Pipeline' started by rickygai, Dec 3, 2023.

  1. rickygai

    rickygai

    Joined:
    Mar 9, 2022
    Posts:
    102
    Unity Editor 2022.3.10f1

    I have the Assets\Settings below.

    upload_2023-12-3_13-54-55.png

    The AR Camera is set to use the "Universal Render Pipeline Asset", but if I click on the AR Camera, it shows the renderer is using URP-HighFidelity and there is no option to choose the "Universal Render Pipeline Asset".

    upload_2023-12-3_13-56-26.png

    The Project Settings\Graphics is set to "Universal Render Pipeline Asset" already but the AR Camera renderer still choose URP-HighFidelity-Renderer always.

    If I removed URP-HighFidelity-xxx then the AR Camera selected the "Universal Render Pipeline Asset" like below.

    upload_2023-12-3_14-0-30.png

    Any idea ?
     
  2. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    4,843
    It's probably the one selected in Quality or Graphics settings