Search Unity

  1. Get the latest news, tutorials and offers directly to your inbox with our newsletters. Sign up now.
    Dismiss Notice

Bug URP 2D Renderer changes Scene window background to black and glitchy

Discussion in 'Editor & General Support' started by c8theino, Mar 12, 2021.

  1. c8theino

    c8theino

    Joined:
    Jun 1, 2019
    Posts:
    13
    When I change to Universal Render Pipeline Asset which uses the 2D Renderer in Project Settings -> Graphics, the Scene window's background turns to black and all the sprites become mushy when I drag the scene window around. Everything works fine if I use the 3D Renderer. URP is setup correctly, I followed this tutorial from Brackeys:


    Here's a picture of the mushy scene window:
     
  2. Hell_Skull2

    Hell_Skull2

    Joined:
    Oct 12, 2019
    Posts:
    1
    Using solid color as background in camera component settings fixed it for me.
    The problem is in skybox. to fix issue in scene in scene window's top bar you can toggle Skybox.
    I guess we can't use skybox with 2d renderer.

    The workaround is to use two renderers and two cameras. one base camera and forward renderer for skybox and overlay camera and 2d renderer for everything else
     
    Last edited: Mar 13, 2021
    c8theino likes this.
  3. c8theino

    c8theino

    Joined:
    Jun 1, 2019
    Posts:
    13
    Thanks, that fixed it for me too. I was unaware that you can toggle the skybox in Scene view...
     
unityunity