Search Unity

Upgrade from 2018.314f1 to 2018.4.0f1 woes

Discussion in 'Editor & General Support' started by katasteel, May 17, 2019.

  1. katasteel

    katasteel

    Joined:
    Nov 21, 2014
    Posts:
    182
    Error log is filling up with this error

    Graphics.CopyTexture can only copy between same texture format groups (d3d11 base formats: src=27 dst=9)

    And my screen is very dark.

    Works fine under 2018.314f1.

    Using Linear/Deferred for color space/rendering path.


    Any ideas?
     
  2. katasteel

    katasteel

    Joined:
    Nov 21, 2014
    Posts:
    182
    Ok so it looks like that error is coming from post processing version 2.1.6.
    Any ideas why that is?

    But the main problem is the screen is way to dark to play now.
    Any ideas why this may be?
     
  3. katasteel

    katasteel

    Joined:
    Nov 21, 2014
    Posts:
    182
    I did notice that it changed all my fbx files (it checked convert units).
    So everything was way too small to see.
    Also my GUI images are not transparent anymore.

    And then there is whatever is making the scene way too dark.

    It seems 2018.4 is not ready for prime time yet.
    I guess I'll wait to upgrade till they get the kinks worked out of it.
     
  4. Lurking-Ninja

    Lurking-Ninja

    Joined:
    Jan 20, 2015
    Posts:
    4,634
    If you think your problems aren't setting mistakes but engine problems, submit bug reports about them instead of waiting, if they are really bugs, Unity needs to know about them to fix them.
     
  5. LilGames

    LilGames

    Joined:
    Mar 30, 2015
    Posts:
    208
    Same error here suddenly started, in Editor (not play mode). Unity 2018.3.8f1

    In fact, now it's spitting out
    RenderingCommandBuffer: invalid pass index N in DrawMesh
    and a ton of other errors.
     
    Last edited: May 23, 2019