Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Unsupported compiler 'GCC 4.2' selected for architecture 'i386'

Discussion in 'iOS and tvOS' started by dominic600, Nov 20, 2011.

  1. dominic600

    dominic600

    Joined:
    Nov 19, 2011
    Posts:
    48
    First time building in xCode, getthing this error "Unsupported compiler 'GCC 4.2' selected for architecture 'i386'
    "

    Just exported into xCode from Unity at first was getting like tons of errors and 1 warning and that quit happing and now its doing this.

    Ive looked around on google and other fourms but everyone just says they fixed it, they dont explain what they did.

    Thanks for any info!
     
  2. Moonjump

    Moonjump

    Joined:
    Apr 15, 2010
    Posts:
    2,574
    I've seen that error in the past. I think it was when Xcode was set to Simulator. Change it in the window on the top-left (assuming you are using Xcode 4).