Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Unityhub fails to start on Linux mint 21 "Vanessa"

Discussion in 'Linux' started by coppersoft, Aug 22, 2022.

  1. coppersoft

    coppersoft

    Joined:
    Aug 30, 2017
    Posts:
    6
    Hello,

    I'm running Linux Mint 21 "Vanessa", I followed this guide

    https://docs.unity3d.com/hub/manual/InstallHub.html#install-hub-linux

    but when I try to launch the unityhub it remains stuck, nothing happens and after a while a popup appears with the following message:

    The Hub as encountered a critical error and must be close. You can report a bug using our bug reporter tool

    And then closes. A dmesg shows this:

    [11008.386190] traps: Chrome_IOThread[22540] trap int3 ip:564fbcfd3627 sp:7f8898dfb7a0 error:0 in unityhub-bin[564fbb0af000+5024000]
    [12990.976161] traps: Chrome_IOThread[24366] trap int3 ip:562afd90e627 sp:7f1134cc97a0 error:0 in unityhub-bin[562afb9ea000+5024000]
    [13071.015189] traps: Chrome_IOThread[24683] trap int3 ip:56339808d627 sp:7f5ec6abe7a0 error:0 in unityhub-bin[563396169000+5024000]

    Please help!
     
  2. coppersoft

    coppersoft

    Joined:
    Aug 30, 2017
    Posts:
    6
    Any hint? I'd love to use unity on Linux mint...
     
  3. ChiwTheNeko

    ChiwTheNeko

    Joined:
    Mar 24, 2022
    Posts:
    150
    Did you try starting the hub in a terminal and see what it says?

    Vanessa is based on Ubuntu 22.04. This version of Ubuntu has a newer version of LibSSL that is not compatible with Unity. If only the Unity devs would distribute Unity as a Flatpak then this kind of compatibility issue would not exist but they don't want to for some reasons. Until then you can check the other thread on this forum that explains how to run Unity on Ubuntu 22.04. This will apply to Mint Vanessa as well.
     
    coppersoft likes this.
  4. coppersoft

    coppersoft

    Joined:
    Aug 30, 2017
    Posts:
    6
    Yes, I must give it a try. Thank you.