Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Unity2019

Discussion in 'Editor & General Support' started by welby, Apr 26, 2019.

  1. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    So I got the HUB thing, installed 2019

    but when I try to open recent projects I get this error.

    Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)
    Copyright (C) Microsoft Corporation. All rights reserved.

    error CS2011: Error opening response file 'H:\Temp/UnityTempFile-59872dbc8657caf4c867cef99a149937'
    warning CS2008: No source files specified.
    error CS1562: Outputs without source must have the /out option specified


    I tried making sure I installed it in a new folder I made and not the default C:program files. But it didn't work.

    any help would be appreciated.
     
  2. MSplitz-PsychoK

    MSplitz-PsychoK

    Joined:
    May 16, 2015
    Posts:
    1,278
    From your project folder, try deleting your Library folder, .sln files, and .csproj files and reopen the project.

    If that doesn't work, try updating visual studio.

    If that doesn't work, try (in unity) going to "Edit->Preferences->External Tools" and changing your external script editor.

    Good luck!
     
  3. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    Sadly a no go.

    I try opening a fresh new Empty Unity 2019 and it gives me that error. I even updated to Visual 2019.
    Not sure what's up.

    I'll stick to 2018 for now, I guess.
     
  4. Dover8

    Dover8

    Joined:
    Aug 20, 2010
    Posts:
    92
    I'm getting this issue too on my PC. No problem on my Macbook Pro.

    I've tried uninstalling/reinstalling everything I can think of - Unity, Unity Hub, Visual Studio. Happens on existing and brand new project.
     
  5. theApper

    theApper

    Joined:
    Apr 29, 2019
    Posts:
    3
    me to! I'm using windows 8. help pls!
     
  6. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    yep,..Windows 10 (64-bit)here.
     
  7. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,675
    Why didn't you use VS 2017? It works very well with 2019.1.
     
  8. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    That's what I had originally when it gave me the error, so I updated. I will try removing 2017 and reInstalling that.
     
  9. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,675
    I don't think Unity is adapted to VS 2019 yet. If you deinstall everything, before installing VS, you should download Unity using the "Unity Hub" button and see what version of VS is available in the modules list,

    I suspect that the VS module will show in the list only if no version of VS are installed in your computer. I'm sorry, I don't want to deinstall VS just to make sure that my theory is right... So, I need a guin tester. :p
     
  10. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    Maybe I will try wiping everything. 2018 works fine though. Hmm,..but I am not using HUB to access 2018 so maybe it's the HUB? I use the HUB for 2019.

     
  11. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,675
    What Scripting Runtime version are you using? See in Player Settings/Configuration. It should be .NET 4.x. Equivalent.
     
  12. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    Yep. I wonder if there is a setting In Visual that I am forgetting.

     
  13. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,675
    Are you sure you have everything installed in VS? Mainly "Game development with Unity" in Visual Studio Installer/Workloads.
     
  14. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    I'll check that next. in the meantime this may be a clue,..I found the files the console was refering too,..it's looking for them in H: but I store them on my C:. and I don't know how to "point" it to C: not H:.




    so weird.,. Unity 2018 works with Visual 2019. but Unity 2019 doesn't
     
  15. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    3,675
    Aw... I have no idea how to do that either. :(
     
  16. Dover8

    Dover8

    Joined:
    Aug 20, 2010
    Posts:
    92
    You have hit the nail on the head. I keep most of my projects on a second drive too, D: in my case. Even if I create a brand new project on my D: drive I get these errors.
    Code (CSharp):
    1. Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)
    2. Copyright (C) Microsoft Corporation. All rights reserved.
    3.  
    4. error CS2011: Error opening response file 'C:\Temp/UnityTempFile-a9ca5cbebe8ea004990de689ccfb95af'
    5. warning CS2008: No source files specified.
    6. error CS1562: Outputs without source must have the /out option specified
    Creating one on the C: drive has no issues, as that's where the above is looking for the files. @welby is your Unity installed on the H drive?
     
  17. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,113
    Could you please submit a bug report with a minimal reproduction project for this issue?
     
  18. Dover8

    Dover8

    Joined:
    Aug 20, 2010
    Posts:
    92
    Will do. My colleagues have been unable to replicate it on their machines, so it seems like a very specific setup or software issue.
     
  19. JoshPeterson

    JoshPeterson

    Unity Technologies

    Joined:
    Jul 21, 2014
    Posts:
    4,545
    @Dover8, @welby:

    This may be related to the temporary directory setting on your machines. What is the value of the TEMP environment variable on each machine?
     
  20. theApper

    theApper

    Joined:
    Apr 29, 2019
    Posts:
    3
    Try deleting packages like TextMeshPro. It helped me
     
  21. konsic

    konsic

    Joined:
    Oct 19, 2015
    Posts:
    995
    C:\TMP on mine
     
  22. welby

    welby

    Joined:
    Mar 22, 2011
    Posts:
    549
    It's an empty New instance of UNity2019.

    UNity is installed on C:

    my windows TEMP environment point to my C:\Users\tonyt\AppData\Local\Temp

    but I am using a roaming profile pointing too but
    none of my environment variables mention H:


    Is there something else within Unity that determines the Temp path?



     
  23. Dover8

    Dover8

    Joined:
    Aug 20, 2010
    Posts:
    92
    For my User variable it's
    %USERPROFILE%\AppData\Local\Temp
    Which is a C: path

    There is also a TMP System variable pointing to
    %SystemRoot%\TEMP
     
  24. JoshPeterson

    JoshPeterson

    Unity Technologies

    Joined:
    Jul 21, 2014
    Posts:
    4,545
    Thanks for the details all, we are investigating this now.
     
  25. RobinParkUnity

    RobinParkUnity

    Unity Technologies

    Joined:
    Jan 23, 2017
    Posts:
    1
    For more of your information, when removing the following 4 packages from manifest.json one by on, each error disappears respectively, but with each of 5 features. This could be a clue to solve the problem.

    "com.unity.analytics": "3.3.2",
    "com.unity.collab-proxy": "1.2.16",
    "com.unity.package-manager-ui": "2.1.2",
    "com.unity.textmeshpro": "2.0.0",
    "com.unity.timeline": "1.0.0",
     
    Last edited: May 25, 2019
  26. sarahchen1

    sarahchen1

    Joined:
    Jul 11, 2019
    Posts:
    1
    I'm having a similar issue

    Code (CSharp):
    1. Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e)
    2. Copyright (C) Microsoft Corporation. All rights reserved.
    3.  
    4. error CS2011: Error opening response file 'C:\Temp/UnityTempFile-f04c776e2c86b794eb6c3fe499aa4541'
    5. warning CS2008: No source files specified.
    6. error CS1562: Outputs without source must have the /out option specified
    7.  
    My Windows TEMP points to C:\Users\SarahC\AppData\Local\Temp
    Are there any updates on this thread?
     
  27. JoshPeterson

    JoshPeterson

    Unity Technologies

    Joined:
    Jul 21, 2014
    Posts:
    4,545
    I don't have any updates on this issue, sorry. I can't immediately track down the bug report for this. The value of the TEMP environment variable on your machine looks like the default value, so that is probably fine. Can you submit a bug report that reproduces this issue?
     
  28. LordSmokin

    LordSmokin

    Joined:
    May 10, 2017
    Posts:
    1
    Hi Everybody, been reading through this thread because I had run into a similar issue. I tried to resolve the problem by deleting my temp files, making adjustments to my player settings, uninstalling/reinstalling, etc but none of that seem to help.

    Before I ran into this issue, I had copied over my files from one computer to another (which I think was mentioned above by another user). What ultimately resolved my issue was to export all of the assets from the project, created a new project on the second PC, and importing a custom package with all of the desired assets.

    My original project was built in Unity 2019.3.0a2 and the version of Unity I imported my assets into is Unity 2019.3.0a8. (Not sure if this will make a difference).

    Hope that helps.

    Cheers,
     
    Last edited: Jul 15, 2019
  29. VeinLeint

    VeinLeint

    Joined:
    Feb 4, 2016
    Posts:
    5
    I have this issue as well, I'm trying to fix it for 2 weeks now. The thing is that, even if you create a new project, the errors still appears. Right away from the start. Is there any update on Unity fixing this?
     
    Dover8 likes this.
  30. VeinLeint

    VeinLeint

    Joined:
    Feb 4, 2016
    Posts:
    5
    By the way, I have try all of the Unity version from 2019.1, and all of them give me the same issue.
     
  31. Qazydude

    Qazydude

    Joined:
    Aug 20, 2019
    Posts:
    1
    I ran into a similar issue recently. For me going into regedit and deleting the HKEY_CURRENT_USER\SOFTWARE\Microsoft\Command Processor\Autorun key did the trick.
     
    animeistrash and dome1993 like this.
  32. Dover8

    Dover8

    Joined:
    Aug 20, 2010
    Posts:
    92
  33. JoshPeterson

    JoshPeterson

    Unity Technologies

    Joined:
    Jul 21, 2014
    Posts:
    4,545
    No, we don't have any updates, unfortunately. We've not had a bug report submitted for this issue from what I can tell, and we cannot reproduce it ourselves. If you can submit a bug report, that would really help.
     
  34. Renanmgs

    Renanmgs

    Joined:
    May 16, 2016
    Posts:
    31
    Hi @JoshPeterson , just got this bug as well.
    upload_2019-11-30_15-47-37.png

    Submitted a bug report (Case 1202156).
     
    JoshPeterson likes this.
  35. CorvOrk

    CorvOrk

    Joined:
    Jun 25, 2015
    Posts:
    4
    Had the same problem. Recently I`m installed Anaconda package on current machine. Anaconda changed AutoRun with follow value: "C:\Users\CorvOrk\AppData\Local\Temp\_MEI124002\condabin\conda_hook.bat".

    When I was running Unity (2019 and 2020 failed but 2018 work fine) I got error "Microsoft (R) Visual C# Compiler version 2.9.1.65535 (9d34608e) Copyright (C) Microsoft Corporation."

    After deleting AutoRun all work fine. (You should delete AutoRun from regestry with path "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Command Processor\Autorun").
     
    Dover8 likes this.
  36. Cyrussphere

    Cyrussphere

    Joined:
    Jul 1, 2016
    Posts:
    127
  37. nameuse

    nameuse

    Joined:
    Nov 8, 2017
    Posts:
    4
    1) Open :
    Regedit

    2) Go to this folder :
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Command Processor\

    3) Delete :
    Autorun
     
    Dover8 likes this.
  38. unity_-czh6Add1XgRzg

    unity_-czh6Add1XgRzg

    Joined:
    May 16, 2018
    Posts:
    1
    The above solutions didn't exactly work for me, but they helped.

    In my regedit, the Command Processor folder at this path does NOT have any key named Autorun:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Command Processor\

    I looked for other Software folders on the other HKEY_.... trees, and found Autorun here:
    \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor

    I'd set it to automatically open my cmd in my local Github directory.
    After deleting the key and closing/reopening Unity 2019.3.14.f1, I no longer get the error.
    I was previously seeing this:
    Code (CSharp):
    1. Temp/UnityTempFile-1e577c21e6c4d6a46a649a5c8a30988a' warning CS2008: No source files specified.
    2.PNG
     
unityunity