Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Unity Web Player Is Installed But Is Not Working

Discussion in 'Editor & General Support' started by FanboyStudios, Apr 26, 2016.

  1. FanboyStudios

    FanboyStudios

    Joined:
    Apr 26, 2016
    Posts:
    3
    I have been trying to play Contract Wars, a Facebook Game and it does not load. Other unity web player games work (now not anymore) and the problem seems to be on my system. I am a newbie dev and a newbie unity dev, so please don't tell me to clear cache or things like that as i've already tried them. How can I do a complete uninstall? (all unity web player files should be deleted, but leave my unity web editor alone) as from what i understand some files remain.
     
  2. dormouse

    dormouse

    Joined:
    Mar 1, 2011
    Posts:
    65
    make sure you have installed your unity web player plugin.
    right click on your web browser, choose 'run as administrator' then take a look at the webpage made by Unity.
     
  3. Mauri

    Mauri

    Joined:
    Dec 9, 2010
    Posts:
    1,595
    1. Forget the Webplayer. Unity does not plan to support it any further. WebGL is the future.
    2. If you're using Chrome: it won't work anymore, because Google deprecated NPAPI long time ago. You could try using Firefox (although Mozilla has similar plans to unsupport NPAPI), Opera...
    3. Uninstalling the Webplayer Plug-in for web browsers does not interfere with the Unity Editor. Just uninstall it like you would normally uninstall a software.
     
  4. FanboyStudios

    FanboyStudios

    Joined:
    Apr 26, 2016
    Posts:
    3
    1. Is not an option Contract Wars on Facebook requires Unity Web Player.
    2. Opera is now a Chrome Clone... Updated it and websites now see opera as Chrome. :(
     
  5. Mauri

    Mauri

    Joined:
    Dec 9, 2010
    Posts:
    1,595
    That's the fault of the 'Contract Wars' developers, then. Unity Technologies is only providing the tool (Unity Editor) for other game developers who wants to make games. Try Firefox - NPAPI plug-ins are still working there.
     
  6. FanboyStudios

    FanboyStudios

    Joined:
    Apr 26, 2016
    Posts:
    3
    https://unity3d.com/webplayer/setup works fine... game still doesn't load.
    Firefox don't work wit Facebook Contract Wars, however it does with Miniclip Contract Wars. My Facebook CW is my main with almost every gun in the game $200-$300 worth of weaponry.
     
  7. Mau-

    Mau-

    Joined:
    Jan 21, 2017
    Posts:
    1
    Working just on CHROME, S*** browser.
     
  8. DeathOpsMama

    DeathOpsMama

    Joined:
    Mar 16, 2017
    Posts:
    1
    IE browser still works with Contract Wars, but the view/zoom in or out feature does not help it to be viewable, it appears to view too large on my screen, I have to use "Full screen" in order to view it correctly. But I sure wish someone would fix Unity and Firefox so they would work together. I have even tried turning off the security feature on Firefox that is built in. grrrrrrrrrrr
     
  9. DamianDD04

    DamianDD04

    Joined:
    Mar 17, 2017
    Posts:
    1
    I play pixel warfare 3 and i updated Firefox and it say that i need unity web player i already downloaded it and it did work but i got to permissions and i cant find unity web player so i try re-downloading and its still not there need help :(
     
  10. dastardly56

    dastardly56

    Joined:
    Mar 20, 2017
    Posts:
    1
  11. Imtyaz

    Imtyaz

    Joined:
    May 9, 2017
    Posts:
    6
  12. IzzyTheProducer

    IzzyTheProducer

    Joined:
    Oct 2, 2018
    Posts:
    1
    The reason it may not be working on mozilla in 2018 is because you have to install mozilla ESR 50.0 and then turn off automatic updates by
    *Going to the options panel
    *Go to "Advanced" tab
    *Go to the "Updates"tab
    *Turn off Automatic updates
    And you're all set!
    for some odd reason it stops working on mozilla 60.0, and then starts asking to you download and install mozilla an infinite amount of times. Hope this helped, good luck!