Search Unity

Unity Vuforia iOS build crashes with same EXC_BAD_ACCESS code

Discussion in 'Editor & General Support' started by sstachiw, Feb 6, 2019.

  1. sstachiw

    sstachiw

    Joined:
    Jan 5, 2019
    Posts:
    13
    This is driving me insane. I have a fairly large app that uses Vuforia to place a plane in the scene. This plane has a Video player with a render texture. I have an array of 120 short video clips. The app is a "choose your own adventure" style game where the video clip plays and the user makes a choice that changes what video clip plays next.

    It is crashing at random times. When plugged into Xcode, I get the exact same error code every time. It is a EXC_BAD_ACCESS that seems to be connected to the VideoPlayer. If I check the Zombies box and run the profiler I get a different error referencing the VIOEngineNode.

    Has anyone experienced this or, looking at the attached images, know where I should start looking?

    EDIT: I am using the latest Unity and Vuforia builds as of 2/4/19 and Xcode 10.1. Test device is iPad with iOS 12.1.3
    Screen Shot 2019-02-01 at 5.36.49 PM.png Screen Shot 2019-02-05 at 4.54.05 PM.png
     
  2. MontanaAnton

    MontanaAnton

    Joined:
    Feb 16, 2014
    Posts:
    5
    also crushes in version 2019.1.0f2 but without vuforia
    happens when i enable gameobject from bundled scene Screenshot at Apr 24 13-02-29.png

    EDIT: solved
    disable Strip engine Code in Project settings
     
    Last edited: Apr 24, 2019
    seanbiganski likes this.