Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Nominations have been announced for this years Unity Awards. Celebrate the wonderful projects made by your peers this year and get voting! Vote here!
    Dismiss Notice
  6. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Unity version usage [Updates Now in Publisher Forum]

Discussion in 'Assets and Asset Store' started by Aras, Jun 10, 2014.

Thread Status:
Not open for further replies.
  1. Elzean

    Elzean

    Joined:
    Nov 25, 2011
    Posts:
    576
    I agree too.

    My main issue with the other graph is because i'm color blind and i have lots of troubles to figure out which versions are on the graph...
     
    twobob likes this.
  2. AnneSchmidt

    AnneSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    1,154
    I have the same problems, but I'm not colour blind. :)
     
  3. TooManySugar

    TooManySugar

    Joined:
    Aug 2, 2015
    Posts:
    853
    Still on 4.7.2 Now starting to consider to move to incoming versions due to Vulkan Single pass VR & The lightmapper which is essentially Beast whitch should have NEVER been removed. But theese features still seem to be in too early stage so....
     
  4. Cuboom

    Cuboom

    Joined:
    Feb 28, 2017
    Posts:
    9
    Update would be nice. Thanks
     
  5. s0manyth1ngs

    s0manyth1ngs

    Joined:
    Jan 9, 2017
    Posts:
    15
    Anyone have an update on version usage?

    I'm preparing my first package as a publisher for the Asset Store. I would like to prep multiple versions so people don't have to rebuild broken materials, but I'm noticing even different packages within the same version seem to break assets (i.e. 5.0 to 5.6). It would be really useful to know the most common used versions for each unity build so publishers can prep/update accordingly and developers don't have to deal with broken assets.

    Thanks!
     
    Qbit86 likes this.
  6. LightingBox2

    LightingBox2

    Joined:
    Mar 31, 2015
    Posts:
    2,729
    5.4.1 should be enough.. Older versions does not support next-gen graphics features. And newr versions dose not has important features.
     
  7. Peter77

    Peter77

    Joined:
    Jun 12, 2013
    Posts:
    2,821
    I second that!
    I also believe the "editor sessions" statistic is more useful than "editor downloads". As an asset store publisher, I'm interested to know how often a certain editor version is being used, rather than how often it has been downloaded.
     
  8. larku

    larku

    Joined:
    Mar 14, 2013
    Posts:
    1,411

    Could we possibly get some updated stats?
     
  9. SoundStormLabs

    SoundStormLabs

    Joined:
    May 6, 2017
    Posts:
    148
    Is there any update on the most recent versions? Where could I find this information? I literally did ctrl+f+"analytics" and the word "analytics" does not exist on Unity's home page, so I have no idea where to look.
     
    alexanderameye and Nyarlathothep like this.
  10. AltSoftLab

    AltSoftLab

    Joined:
    Jul 25, 2014
    Posts:
    79
    Please update. Thanks
     
    LightingBox2 likes this.
  11. Nairda_Draziw

    Nairda_Draziw

    Joined:
    May 3, 2014
    Posts:
    18
    This is a valuable information. I add my voice, please update it.
     
    LightingBox2 likes this.
  12. AndrewAssetStore

    AndrewAssetStore

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    818
    There is updated information in the Publishers forum.

    To Join the Publishers Forum - Active Publishers Only
    1. Refer to the email you receive when a package is accepted to the store.
    2. Find the section with the title "Continue the Conversation!"
    3. Fill out the form. Once a week or so, we'll go through and approve publishers. You'll then have access to the forum, which will be visible at the very bottom of the forum contents page.
     
    Last edited: Aug 14, 2017
    zwcloud, Peter77 and Mikilo like this.
  13. Mikilo

    Mikilo

    Joined:
    Jan 29, 2013
    Posts:
    362
    How can we access this forum?
     
  14. AndrewAssetStore

    AndrewAssetStore

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    818
    To Join the Publishers Forum - Active Publishers Only
    1. Refer to the email you receive when a package is accepted to the store.
    2. Find the section with the title "Continue the Conversation!"
    3. Fill out the form. Once a week or so, we'll go through and approve publishers. You'll then have access to the forum, which will be visible at the very bottom of the forum contents page.
     
  15. Mikilo

    Mikilo

    Joined:
    Jan 29, 2013
    Posts:
    362
  16. syscrusher

    syscrusher

    Joined:
    Jul 4, 2015
    Posts:
    876
    Hello, @AndrewAssetStore

    I read your August 14 post, but that poses a problem here. I have an asset that I'm getting ready to submit to the store, but I need to decide how far back to support as I publish it. I've tested on Unity 5.4, 5.5, 5.6, 2017.1, and 2017.2, but I am not sure whether it's worth supporting 5.4 or not. Since this is my first submission to the Store, I can't follow your suggestion to join the publishers' forum. Is there any other way to get a snapshot of the version usage data?
     
  17. TonyLi

    TonyLi

    Joined:
    Apr 10, 2012
    Posts:
    8,637
    As of June 25, the number of users who used Unity for a significant amount of time were roughly:

    Unity 5.6 and 2017: 65%
    Unity 5.5: 18%
    Unity 5.4: 8%
    Unity 5.3: 5%
    Unity 5.2: 1%

    I'm eyeballing a chart, and I don't represent Unity, so please take this as completely unofficial.

    My recommendation is to release on Unity 5.5+, since by now the percent of users on 5.4 is probably even lower.
     
  18. Eric5h5

    Eric5h5

    Volunteer Moderator Moderator

    Joined:
    Jul 19, 2006
    Posts:
    31,899
    If you've already tested on 5.4, and the percentage of users is more than zero, it seems a waste not to support it.

    --Eric
     
  19. TonyLi

    TonyLi

    Joined:
    Apr 10, 2012
    Posts:
    8,637
    I was once the fence about suggesting that. I think you're right, though. The major API changes are from 5.5 to 5.6, versus 5.4 to 5.5, so the additional support burden shouldn't be much. The thing that put me on the fence was that, as new Unity versions come out, the tail of older versions grows. There's something to say for making that tail reasonably short to start with.
     
  20. syscrusher

    syscrusher

    Joined:
    Jul 4, 2015
    Posts:
    876
    Thanks, to both of you, for the extremely helpful replies.

    My code works on 5.4 through 2017.2 with zero conditional compiles, so there's no extra "burden" to support 5.4. My concern was just what @TonyLi says, that I don't want to immediately start with a long tail of versions. The issue is my need to test with all those versions, plus new ones as they emerge, each time I fix a bug or add a feature.

    Food for thought. I haven't made a final decision yet, but you've given me the raw data I need to make a well-informed decision. Many thanks!
     
  21. DerDicke

    DerDicke

    Joined:
    Jun 30, 2015
    Posts:
    121
  22. ZimM

    ZimM

    Joined:
    Dec 24, 2012
    Posts:
    942
    Oh well. I guess it's time for me to drop Unity 4.x support... Good riddance.
     
    AndrewAssetStore likes this.
  23. syscrusher

    syscrusher

    Joined:
    Jul 4, 2015
    Posts:
    876
    FWIW, I've decided to support 5.4 through 2017.2, but only (officially) the latest release of each major version (e.g., 5.4.6f3 but not 5.4.5, etc.). My code, even my custom shader, work correctly in all of these versions, modulo Unity's automated API updates along the way, so I see no reason to turn away potential customers. If I were starting from scratch on a new asset, though, I would probably drop 5.4.x and start with 5.5.x based on the numbers from @TonyLi, figuring that by the time I was done, the usage of 5.4 would drop further.

    Thanks again for that info, really helpful.
     
  24. SarfaraazAlladin

    SarfaraazAlladin

    Joined:
    Dec 20, 2013
    Posts:
    279
    Now that it's 2018, I would love to see an updated usage graph :) This thread is an amazing resource for asset store devs.
     
    Qbit86 likes this.
  25. Mikilo

    Mikilo

    Joined:
    Jan 29, 2013
    Posts:
    362
    This is not going to be updated.

    The graph is only available for publishers having access to the forum.

    I put a link above.
     
  26. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    23,840
    I've locked this thread now so that people can stop replying to it and be funnelled to the correct quoted answers.
     
Thread Status:
Not open for further replies.