Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Resolved Unity Transport / NGO "Failed to connect to server" where Unet worked

Discussion in 'Unity Transport' started by Yann_de_Couessin, Aug 23, 2023.

  1. Yann_de_Couessin

    Yann_de_Couessin

    Joined:
    Jan 2, 2015
    Posts:
    42
    Hello !

    I wanted to upgrade my multiplayer project from 2021.3.29f1 to 2022.3.4f1, so I had to switch from Unet(deprecated) to Unity transport.

    But I encountered this "Failed to connect to server" when using the LAN IP + 7777 port.
    If I start on the same machine a build + editor with 127.0.0.1 IP, it works.

    I tried on 3 different machines, 2 different networks (home and office) but still.

    To see it was related to Unity transport and 2022.3.4f1, I tried to reproduce it on a blank project.
    It didn't worked either. I tried to switch back to 2021.3.29f1 but with Unity transport. It still shows the "Failed to connect to server" error after 1 minute or so.

    upload_2023-8-23_10-39-51.png
    upload_2023-8-23_10-39-59.png


    I'm probably missing a Unity transport principe but I can't figure it out even with the doc (I'm a bit confused with the provided Pong & Soak samples)

    Regards !

    Woopsy ! I just had to tick the "allow remote connections" from the unity transport component.
     
    Last edited: Aug 23, 2023