Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Unity stops responding on compile

Discussion in 'Scripting' started by Roldo, Feb 14, 2019.

  1. Roldo

    Roldo

    Joined:
    Oct 25, 2014
    Posts:
    26
    Hello. I have an issue with unity version 2018.3.5f1. After i make any change in my code, unity automatically compiles the scripts and usually stops responding(with like.. 75% chance). I dont know how to fix the issue: i already tried rolling back the update but nothing seems to help. Please help, as its really annoying to restart editor with task manager every time i want to change a string in my code.
     
  2. Joe-Censored

    Joe-Censored

    Joined:
    Mar 26, 2013
    Posts:
    6,529
    Are you sure the editor isn't actually just busy still compiling? Depending on your computer hardware and the size of your project, it can actually take a while to complete.
     
  3. drcrck

    drcrck

    Joined:
    May 23, 2017
    Posts:
    279
    You're not doing it in playmode, right?

    Yeah it's annoying so I made an AutoHotkey script that instantly kills Unity when I press Pause :D
    Code (csharp):
    1. Pause::Run, taskkill /im Unity.exe /f
     
  4. doctorpangloss

    doctorpangloss

    Joined:
    Feb 20, 2013
    Posts:
    233
    Try disabling Windows Defender and any antivirus software you may be running.

    Also, try Reimport All.
     
  5. Roldo

    Roldo

    Joined:
    Oct 25, 2014
    Posts:
    26
    Yes, im am sure, because i guess if it was compiling there was at least some cpu activity, whereas its just drops to 0% :( And my project is not that big(somewhat around 1k lines of code) and should compile pretty fast on my hardware(i7-8700k overclocked, 32gb ram)
     
  6. WarmedxMints

    WarmedxMints

    Joined:
    Feb 6, 2017
    Posts:
    713
    Your overclock may not be as stable as you think and could be causing erros. Try setting your cpu back to stock.