Search Unity

  1. All Pro and Enterprise subscribers: find helpful & inspiring creative, tech, and business know-how in the new Unity Success Hub. Sign in to stay up to date.
    Dismiss Notice
  2. Dismiss Notice

Unity starting from 2020.0 is unusable for me

Discussion in 'Editor & General Support' started by Vefery, Aug 10, 2020.

  1. Vefery

    Vefery

    Joined:
    Feb 23, 2018
    Posts:
    100
    After every major action (like loading scene, creating prefab, playing, etc) "Hold on" window pop up and editor freezes for a few seconds. Now when I imported two huge asset packs (>1gb each) I can't open any scene with objects, "Hold on" window pops up with infinite PlayerLoop or UpdateScene loading. I tried to wait, but even after an hour editor doesn't unfreeze. There's also an issue that the editor crashes when there's at least one skinned mesh in the scene, but I fixed it with increasing TdrDelay
    None of this were happening in previous versions, I successfully used exactly the same assets in my previous projects, more than one character with skinned mesh, etc
    I was able to load assets' showcase scene once and noticed that the performance is much better now, but unfortunately I have to back to 2019 LTS version
     
  2. polemical

    polemical

    Joined:
    Jun 17, 2019
    Posts:
    919
    I've had issues like this in Windows 7 (now primarily using 10 but not long enough to know whether the same thing happens). What I did to work around it is when loading Unity Editor, selected the process in Task Manager - then when the editor would sit there with the popup but nothing apparently happening and like no CPU usage, there was a second Unity.exe running in the Task Manager processes list. I'd know that was the one to close because I had the initial process selected and the new one wasn't - before I figured that out it was guesswork and it's not always the second one listed. So I'd click the new one and end the process and the popup status/progress dialog would disappear and the action would complete / the editor would unfreeze and continue as normal. I'm not sure how far back the issue exists or what exactly causes it to lock up like that, but I first found this "last chance tactic" several alphas ago (2020.2). It has let me save things I've done that I would have lost otherwise if I had to just force the editor to close (which was how I stumbled on this to begin with).
     
unityunity