Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug Unity seems to be using an incompatible Android compiler

Discussion in 'Android' started by TiggyFairy, Apr 11, 2024.

  1. TiggyFairy

    TiggyFairy

    Joined:
    Dec 22, 2019
    Posts:
    542
    I've gotten the Gradle android Compiler working only very briefly. It keeps falling on me as (I think) Unity is using functions that Gradle recommends you update Gradle in order to use. However, doing so breaks Gradle because Unity is also using Depreciated Gradle functions.

    At least, that's what I'm getting from this.


    upload_2024-4-11_10-28-57.png

    Code (CSharp):
    1. Starting a Gradle Daemon, 1 incompatible and 2 stopped Daemons could not be reused, use --status for details
    2. WARNING:We recommend using a newer Android Gradle plugin to use compileSdk = 34
    3.  
    4. This Android Gradle plugin (7.1.2) was tested up to compileSdk = 32
    5.  
    6. This warning can be suppressed by adding
    7.     android.suppressUnsupportedCompileSdk=34
    8. to this project's gradle.properties
    9.  
    10. The build will continue, but you are strongly encouraged to update your project to
    11. use a newer Android Gradle Plugin that has been tested with compileSdk = 34
     
  2. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    3,956
    Your error is

    Code (CSharp):
    1. > Duplicate class bitter.jnibridge.JNIBridge found in modules classes (classes.jar) and unity-classes (unity-classes.jar)
    It seems you're including unity-classes.jar somewhere which is conflicting with Unity's builtin classes.jar.
     
  3. TiggyFairy

    TiggyFairy

    Joined:
    Dec 22, 2019
    Posts:
    542
    Thanks. Seems like it was a compiled addon.