Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Unity Remote 5 NOT working with 2018.3.0f2

Discussion in 'External Tools' started by LurchUSA, Dec 13, 2018.

  1. LurchUSA

    LurchUSA

    Joined:
    Sep 20, 2017
    Posts:
    20
    I just upgraded to Unity 2018.3.0f2, from 2018.2.18f1.

    Before Unity Remote 5, which I was running on an iPad Mini 2 via the USB port was working flawlessly. NOW it does NOT work at all.

    When I am running Unity and plug in my iPad Mini 2, I get the following error messages:

    EntryPointNotFoundException: StartIosProxy
    UnityEditor.iOS.iOSDevice.StartIosProxy (System.UInt16 devicePort) (at C:/buildslave/unity/build/PlatformDependent/iPhonePlayer/Extensions/Common/iOSDevice.cs:46)
    UnityEditor.iOS.iOSDevice.StartRemoteSupport () (at C:/buildslave/unity/build/PlatformDependent/iPhonePlayer/Extensions/Common/iOSDevice.cs:54)
    UnityEditor.IDeviceUtils.StartRemoteSupport (System.String deviceId) (at C:/buildslave/unity/build/Editor/Mono/Utils/IDeviceUtils.cs:14)

    Could not start remote support for device: EntryPointNotFoundException: StartIosProxy
    UnityEditor.iOS.iOSDevice.StartIosProxy (System.UInt16 devicePort) (at C:/buildslave/unity/build/PlatformDependent/iPhonePlayer/Extensions/Common/iOSDevice.cs:46)
    UnityEditor.iOS.iOSDevice.StartRemoteSupport () (at C:/buildslave/unity/build/PlatformDependent/iPhonePlayer/Extensions/Common/iOSDevice.cs:54)
    UnityEditor.IDeviceUtils.StartRemoteSupport (System.String deviceId) (at C:/buildslave/unity/build/Editor/Mono/Utils/IDeviceUtils.cs:14)
     
  2. wagenheimer

    wagenheimer

    Joined:
    Jun 1, 2018
    Posts:
    82
    It seems to be also not working with Android Devices.
     
  3. wagenheimer

    wagenheimer

    Joined:
    Jun 1, 2018
    Posts:
    82
    And I have the exact same error with my iPad. But this workaround worked!

    https://forum.unity.com/threads/ipad-w-unity-remote-broken-on-windows.405016/

    You can copy this from any older version of Unity.

    "you can go to your Unity install folder and copy editor\Data\PlaybackEngines\iOSSupport\x86_64\*.* one level up into iOSSupport folder. This is for 64bits, for 32bits replace x86_64 with just x86. The native library will load then and those errors should go away."
     
    Last edited: Dec 18, 2018
    AAK_Lebanon and samuelykc like this.
  4. wagenheimer

    wagenheimer

    Joined:
    Jun 1, 2018
    Posts:
    82
    Workaround for Android, when not working :

    Setup in Unity: “Unity Remote Editor Settings> Device> Any Android Device”

    Then:

    1. Open a command window.

    2. Navigate to your Android ADB folder. (For Windows Users, C:\Users[UserName]\AppData\Local\Android\sdk\platform-tools)

    3. Kill the adb server with the following command: adb kill-server

    4. Restart the adb server: adb start-server

    5. Open Unity Remote on your device.

    6. Press play.
    Repeat whenever you encounter this issue.
     
    Last edited: Dec 20, 2018
    Knyron and MeteoSerpent101 like this.
  5. Lelefant

    Lelefant

    Joined:
    Jul 1, 2015
    Posts:
    20
    I got the same issue after upgrading from 2018.3.0f1 to 2018.3.0f2.

    This is a section from the editor log after starting play mode with an Android device attached (recognized in build settings):

     
    Last edited: Dec 20, 2018
  6. XantRoss

    XantRoss

    Joined:
    Dec 31, 2018
    Posts:
    2
    Any one fixed the issue for IOS?? in 2018.3.0f2 is not working and not in the new 2019.1.0a12 (so even in 2019 it's not fixed).
     
    AAK_Lebanon likes this.
  7. unity_1SeL-HQ69UMA9g

    unity_1SeL-HQ69UMA9g

    Joined:
    Oct 7, 2017
    Posts:
    8
    Still dont working :(
     
  8. andrenospam0

    andrenospam0

    Joined:
    Oct 28, 2018
    Posts:
    6
    Got the same issue. Now fixed with 2018.3.12f
     
  9. SauronDark

    SauronDark

    Joined:
    Mar 2, 2017
    Posts:
    13
    not fixed on 2019.1, android debug is on, tried restart editor, but no response from Remote 5
     
  10. ellenblomw

    ellenblomw

    Joined:
    Mar 4, 2018
    Posts:
    152
    Having the same problem. But I don't even have a X86 folder in there. What to do then?

    "you can go to your Unity install folder and copy editor\Data\PlaybackEngines\iOSSupport\x86_64\*.* one level up into iOSSupport folder. This is for 64bits, for 32bits replace x86_64 with just x86. The native library will load then and those errors should go away."