Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Bug Unity Project not opening through unity hub

Discussion in 'Unity Hub' started by TwiTechGamesStudio, Sep 24, 2022.

  1. TwiTechGamesStudio


    Sep 24, 2022
    Recently(since I updated to hub 3.3.0) I have been encountering an issue. When I open my project through the hub it loads, then opens the slash screen of the project and closes automatically and the hub reloads. I've tried multiple things I tried setting the license manually and it doesn't work, I re-installed the hub and that too doesn't work. But on another device with an older version of the hub it works well.

    I am not able to open my project. The only thing that happens is the change in the cursor and a glimpse of the splash screen and unity hub restarting again. I tried opening a scene directly through the file manager and it opens but shows errors in scripts that I never edited. I want a way to either fix the issue or downgrade my unity hub version to one of the previous working releases.
  2. nheng


    Mar 15, 2021
    I had the same issue recently on OSX. As a temporary stopgap, I have found that adding the -logfile command-line argument allowed my project to load normally. However we still need a permanent solution to this bug.
    What OS are you using?

    Edit: Found another solution after the -logfile workaround stopped working. I opened the license page in Unity Hub and reloaded the licenses, and somehow it began working again.
    Last edited: Feb 28, 2023
    pirate2606 likes this.
  3. unity_028AE3B1F1BC5DECE8AD


    Jul 31, 2022