Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question Unity Not Opening Editor from hub or desktop, Editor running as background process in task manager

Discussion in 'Editor & General Support' started by tavishfogarty, Apr 22, 2024.

  1. tavishfogarty

    tavishfogarty

    Joined:
    Apr 7, 2024
    Posts:
    1
    Hello

    I downloaded Unity editor for a school project. When I first downloaded it, I had no problems running it and everything worked fine that first day. I went on vacation for about 2 weeks and when I came back, Unity editor no longer opens.

    First, the Hub would not open at all. I fixed this by uninstalling everything Unity and reinstalling the Hub. I can get the Hub to open now, but every time I try to open the project I was working on, the editor never opens, though it appears in task manager as a background process, after a minute or two it will disappear from task manager, which I assume it means it closed itself.

    I've tried reinstalling the editor, installing a different editor version, getting a new personal/free license and refreshing the license, deleting the license file in the ProgramData/Unity folder (I think the extension was .ufg or something like that), deleting the folders in Local, LocalRow, and Roaming, launching without internet, trying to run as administrator and standard user, nothing seems to work for me.

    The project isn't big, it has one sprite animation that has 6 frames, a png background, and one script with less than 50 lines of code

    I started with version 2022.3.23f1 and when I reinstalled the hub it installed 2022.3.25f1, but neither work. I do have the editor installed on a different drive than my C: because it had more space than my C:, but I don't think this would be a problem as it worked fine the first day I got Unity.
     
    Last edited: Apr 22, 2024
  2. CodeSmile

    CodeSmile

    Joined:
    Apr 10, 2014
    Posts:
    6,943
    Can you create a new project and open that?

    If so, your project may be corrupt or simply not at the location it used to be.
    Otherwise it's either the editor installation or the system itself causing issues.
    Do you run any third party antivirus?