Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question Unity MLAgents environments does not work when I copy (When I duplicate, the environments behave gib

Discussion in 'ML-Agents' started by orhun868, Mar 7, 2024.

  1. orhun868

    orhun868

    Joined:
    Feb 22, 2024
    Posts:
    5
    I am trying to increase the number of environments in order to get faster training time. Simply, I am trying to train a dynamic machine, as you can see in the video below.
    https://drive.google.com/file/d/1HztaaeSNR2xBsHxoQfvjv8rXJlN9zvag/view -> Example Video

    Env2 and Env1 - Env2 detects the product the other one can not detect its own product but detects Env2's product


    When I move the Env2's Product It, you can see Env1 detects it


    The machine is the agent and it has 400 moving parts. But I set them which only the parts are close to the object (let's call it Product) we want to move, will move and get actions at that moment. But when I copy the environment both the environment move by seeing only one product. Both move by one of them but for example, when a product hits a wall, the env must be resetted. But one of the envs is never reset. You can see the codes and the files in my GitHub Repository You can see the video (envProblem.mp4) and some other images and videos in the Docs file in the repo.https://github.com/elymsyr/MLProject