Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Unity Keeps Running iOS Resolver Trying to Install Cocoa Pods

Discussion in 'Editor & General Support' started by DenisKeniMH, Nov 16, 2023.

  1. DenisKeniMH

    DenisKeniMH

    Joined:
    Mar 19, 2022
    Posts:
    1
    Unity keeps trying to run the iOS resolver to install Cocoapods.

    In the terminal, I have checked the following. I've reinstalled the following as well.

    • Ruby version: ruby 3.2.2 (2023-03-30 revision e51014f9c0) [arm64-darwin22]
    • RBenv Global: 3.2.2
    • Pod version: 1.13.0

      Code (JavaScript):
      1. gem install cocoapods --user-install
      2. WARNING:  You don't have /Users/theyashiverse/.gem/ruby/2.6.0/bin in your PATH,
      3.    gem executables will not run.
      4. ERROR:  Error installing cocoapods:
      5.  The last version of drb (>= 0) to support your Ruby & RubyGems was 2.0.5. Try installing it with `gem install drb -v 2.0.5` and then
      6.  
      7. running the current command again
      8.      drb requires Ruby version >= 2.7.0. The current ruby version is 2.6.10.210`
    My friend who is also using the same repo is not experiencing any issues on his end. The ruby version that he is running is 2.6.10.210.

    My understanding is that it is writte into the code or folder hierarchy, but I don't know where to look or edit it on Unity. I've tried using chatgpt and google bard to no luck.



    I am running Unity Version 2020.3.29f1