Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Unity install failed with 1.4.0 on OSX

Discussion in 'Unity Hub' started by pahe, Dec 21, 2018.

  1. pahe

    pahe

    Joined:
    May 10, 2011
    Posts:
    414
    I can't install with the latest Unity Hub version 1.4.0 on OSX 10.13.6 (17G4015). Is there something I need to enable/give permission before installing? Trying to install 2018.3.0f2.

    Bildschirmfoto 2018-12-21 um 09.39.42.png
     
  2. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    1,281
    The error message says it all: you must specify an installation destination first. Click on the cog on the right and choose the place where all your versions of Unity will be installed.

    If you did that already, click on "My Account" and then "Report a bug". :)
     
    pahe likes this.
  3. pahe

    pahe

    Joined:
    May 10, 2011
    Posts:
    414
    Thanks. I tried that, but the install location is always reset, even after I specified the location. Reported a bug, didn't know the Hub has it's own bug reporter tool.
     

    Attached Files:

  4. afshinity

    afshinity

    Unity Technologies

    Joined:
    Jul 31, 2017
    Posts:
    224
    It is a UX bug. The location that you choose is the default location that hub is using. When there is no value in that field it uses the default, and vice versa.
    This issue will be resolved with a new desgin of the hub that we are working on in V2