Search Unity

  1. Megacity Metro Demo now available. Download now.
    Dismiss Notice

Bug Unity Hub , Unity Installed Failed: Validation Failed

Discussion in 'Unity Hub' started by P47HF1ND3R, Feb 19, 2024.

  1. P47HF1ND3R

    P47HF1ND3R

    Joined:
    Feb 5, 2023
    Posts:
    1
    I've done alot of research on this already and I know there so many post out there however non had a decisive working solution to fix this.

    The reason why mine failed was to the following error message


    {"timestamp":"2024-02-19T19:10:14.813Z","level":"info","moduleName":"UnityInstallerWindows","message":"[ 'executing', '\"C:\\\\Program Files\\\\Unity Hub\\\\Unity Hub.exe\"', '-- --winInstaller' ]"}
    {"timestamp":"2024-02-19T19:10:14.893Z","level":"info","moduleName":"UnityInstallerWindows","message":"[ 'user did not agree to the UAC prompt and the process was not started' ]"}
    {"timestamp":"2024-02-19T19:10:14.893Z","level":"info","moduleName":"UnityIPCServer","message":"[ 'IPC server Unity-hubInstallServer closed' ]"}
    {"timestamp":"2024-02-19T19:10:14.893Z","level":"error","moduleName":"UnityInstallerWindows","message":"[ { code: 'User did not grant permission.', message: 'The Hub does not have proper permissions to install Unity.' }, undefined, undefined ]"}

    As you can see it says I did not grant the user enough permission to download however that is not true.
    During the entire downloading and installation process no prompt ever came up raising my attention to need to do anything at all.

    The first time I downloaded a editor it worked fine with no issues whats so ever , however now it wont download and install anything at all

    I've tried reinstalling hub and editor ( both using revo uninstall )
    Changing UAC level
    Running hub as Admin
    Restarting Computer
    Update Windows to latest version

    Ill attach a log so if anyone is interested can see what went wrong

    My guess is that for whatever reason I didn't respond to the UAC prompt and saying yes hence Unity thinks that I said no and you're not allowed to continue however no prompt ever came up which is really bugging me
     

    Attached Files: