Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug Unity Hub not launching editor

Discussion in 'Editor & General Support' started by Vanz, Mar 15, 2023.

  1. Vanz

    Vanz

    Joined:
    Nov 19, 2013
    Posts:
    374
    was working then seemed to stop working after the latest windows 10 update "22H2" I believe, get a spinning circle to the left of the project name but the editor never appears... tried deleting all reference to unity hub and reinstalling and rebooting, still same issue, running editor 2021.3.3f1 LTS

    tried this (see below steps),

    https://forum.unity.com/threads/err...-the-application-path-does-not-excist.692038/

    did not work, any suggestions appreciated.

    Kind Regards,

    Vanz

    I was having the same issue after Noting that My Unity versions were being installed in an undesired location. After uninstalling, then updating the Unity Editor folder(under gear icon), it actually installed but unity maintained a link to the previous installs. Here's how I fixed it:
    - Uninstall Unity Hub
    - Open file explorer and navigate to C:\Users\<Username>\AppData\Roaming and manually delete the Unity Hub directories.
    - Now install Unity Hub
    - Open Unity Hub and navigate to the installs panel and click the locate button.
    - Navigate to where the former version of Unity hub installed the unity version and select the Unity.exe file
    (Drive:\\Path\Version\Editor\Unity.exe obviously changing the Drive:\\Path\Version to proper values: IE: C:\Program Files\Unity\2018.4.22f1\Editor\Unity.exe)
     
    Last edited: Mar 15, 2023
  2. Vanz

    Vanz

    Joined:
    Nov 19, 2013
    Posts:
    374
    if I also do a reboot, don't launch Unity Hub, and try to launch the editor directly from the shortcut it will not launch... this is very strange for me, have never seen this before... Windows will not allow me to recover and go back to a previous version, roll back is greyed out... grrr....

    I do have my entire HD backed up with Acronis, so I could try that but that take a lot of time and this seems like a pretty bad bug to me... ¯\_ (ツ)_/¯

    Been using Unity for years and never had a problem launching an editor before...

    any ideas/suggestions welcome please...

    V
     
  3. Vanz

    Vanz

    Joined:
    Nov 19, 2013
    Posts:
    374
    also tried to run Unity Hub and Unity Editor as an "administrator", did not fix the issue
     
  4. Vanz

    Vanz

    Joined:
    Nov 19, 2013
    Posts:
    374
    bump... any ideas/ suggestions please?

    I've completely uninstalled and reinstalled Unity Hub and the editor three times now and still and am still surprised that it will not load.... circle spin, then nothing...
     
  5. firebird721

    firebird721

    Joined:
    Jun 8, 2022
    Posts:
    101
    UNITY יhub stopped working after or middle downloading new version Unity 2022.2.20

    now its just have loading page and nothing happens

    tried deleting - reinstalling ,all this didnt work


    maybe it connetced to to the new version of editor i wAS downloaing
     
  6. euden_one

    euden_one

    Joined:
    Apr 4, 2022
    Posts:
    33
    Bump

    EDIT: It was ESET deleting mscorlib.dll from mono files.

    Editor.log shows this for unity 2022.3.2f1 LTS

    Reinstalling Unity or Unity Hub or resetting licenses or deleting caches does nothing.
    Another laptop with the same configuration does open this version.

    there's no 'mono' folder inside C:\Program Files\Unity\Hub\Editor\2022.3.2f1\Editor\Data\Managed\
    It looks like a malformed address that should be pointing to C:/Program Files/Unity/Hub/Editor/2022.3.2f1/Editor/Data/MonoBleedingEdge/lib/ instead

    Code (text):
    1.  
    2. Initialize mono
    3. Mono path[0] = 'C:/Program Files/Unity/Hub/Editor/2022.3.2f1/Editor/Data/Managed'
    4. Mono path[1] = 'C:/Program Files/Unity/Hub/Editor/2022.3.2f1/Editor/Data/MonoBleedingEdge/lib/mono/unityjit-win32'
    5. Mono config path = 'C:/Program Files/Unity/Hub/Editor/2022.3.2f1/Editor/Data/MonoBleedingEdge/etc'
    6. Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,server=y,suspend=n,address=127.0.0.1:56956
    7. The assembly mscorlib.dll was not found or could not be loaded.
    8. It should have been installed in the `C:\Program Files\Unity\Hub\Editor\2022.3.2f1\Editor\Data\Managed\mono\4.5\mscorlib.dll' directory.
     
    Last edited: Jun 20, 2023
  7. sir_ian

    sir_ian

    Joined:
    Apr 8, 2022
    Posts:
    1
    Also having this issue, at least in my case, if I try launching from Unity Hub it gives
    ..."message":"[ 'child process exited with code 0' ]"}

    and trying to open the editor .exe from either double clicking or from a cmd does nothing, not even an error message or anything. Also tried reinstalling Hub and the editor multiple times, logging out, re applying the license, and restarting the computer between each action.

    On Windows 10 22H2 (OS Build 19045.3570), Unity Hub 3.6.1 and trying to use the editor 2019.4.31f1 LTS (doing VRChat stuff)
     
    Last edited: Nov 14, 2023