Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Unity Hub not installing modules

Discussion in 'Unity Hub' started by LCStark, Jul 5, 2019.

  1. LCStark

    LCStark

    Joined:
    Sep 13, 2017
    Posts:
    5
    I used Unity Hub 2.0.2 to install the latest stable Unity release (2019.1.8f1). In the "Add modules to your install" section I had three modules selected: WebGL Build Support, Windows Build Support (IL2CPP) and Documentation. Once the installation was complete, I used the Hub to create a new project (using the 2D template) and tried to build it for WebGL target, but it looked like WebGL support didn't install at all. The WebGL section in the Build Settings window had only the "No WebGL module loaded" message and "Open Download Page" button, which led me to download the WebGL build support as a separate file.

    I also checked the installation directory and it seems the Documentation wasn't downloaded either. The Windows build support did install correctly.

    I tried installing Unity (from the Hub) on another machine, on which I also checked the "Android Build Support", but again only the Windows Build support was installed.
     
  2. safaGH

    safaGH

    Unity Technologies

    Joined:
    Mar 12, 2019
    Posts:
    124
    Hello,
    After the editor install, can you check if the modules were detected as installed or not by clicking on the menu at the top right of the editor card in the installs tab. If it's selected then please report a bug through the hub bug reporter so we can investigate the logs.
     
  3. LCStark

    LCStark

    Joined:
    Sep 13, 2017
    Posts:
    5
    Hi!

    Apparently, a new version has been released (2019.1.9f1) and it installs correctly through the hub - all selected modules have been included. I guess the problem is solved, at least for now. Thank you for your help!

    If this happens again, should I post a new thread here, or should I just use the "Report a bug" button in the Hub?
     
  4. safaGH

    safaGH

    Unity Technologies

    Joined:
    Mar 12, 2019
    Posts:
    124
    That's cool ! Yeah It would be better if you report a bug through the bug reporter, at least we have access to the logs. You are welcome anytime.
     
    LCStark likes this.
  5. vwestern

    vwestern

    Joined:
    Sep 4, 2018
    Posts:
    1
    Modules to download don't appear for me at all.
     
  6. safaGH

    safaGH

    Unity Technologies

    Joined:
    Mar 12, 2019
    Posts:
    124
    Which version of the editor are you using ?
     
  7. nvoelzow

    nvoelzow

    Joined:
    Dec 17, 2017
    Posts:
    1
    same issue here with Unity Hub 2.1.0 when trying to install 2019.2.1f1 on macOS - the "base" can be installed but the "add modules" window is completely empty...


    Screenshot 2019-08-21 11.51.20.png
     
  8. safaGH

    safaGH

    Unity Technologies

    Joined:
    Mar 12, 2019
    Posts:
    124
    Hello @nvoelzow ,
    It seems to me as a connectivity problem, maybe it's your network that is having troubles to reach our end. But if you experience this issue again after checking your internet and quitting the hub and opening it again, please report a bug and we will look into your logs.