Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

Unity Hub installed Linux version of Unity Editor will not build projects from command line.

Discussion in 'Editor & General Support' started by kew2001, Mar 17, 2019.

  1. kew2001

    kew2001

    Joined:
    Dec 29, 2015
    Posts:
    10
    When installing the Linux Unity Editor from https://forum.unity.com/threads/uni...s-and-known-issues.350256/page-2#post-4009651

    1) The official installer works and produces a version that can build Linux, OSX and Windows versions from the command line.
    2) The Unity Hub installed version, even when I upgrade to 2018.3.8 fails to build when run from the command line and building a Linux, OSX and Windows version.

    There has been no Linux Release since Dec 2018, so I am currently unable to build my project on a linux server with the same version I am develping with.
     
  2. ChanceEncounter

    ChanceEncounter

    Joined:
    Dec 9, 2014
    Posts:
    5
    I can't get the official installer's version to build from the command line, either. It's throwing up gtk errors.