Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Bug Unity hub : install failed validation failed

Discussion in 'Unity Hub' started by QuetzalDev, Oct 3, 2023.

  1. QuetzalDev

    QuetzalDev

    Joined:
    Oct 13, 2020
    Posts:
    1
    I uninstalled the unity editor because i've been trying to download the iOS support module for weeks and it fails in every way possible, as a last resort i uninstalled the editor as a whole to see if maybe a clean install would work and now with the newest unity hub version 3.5.2 i cant even install the editor.
    Things i've tried that resulted in the same validation failed message:
    • Launching unity hub as administrator
    • Relaunching the hub and trying to redownload
    • Reinstalling the hub
    • Reinstalling on a different disc
    After this i manually installed the editor and adding it to the hub which results in no module install option.

    I require both android support and iOS support for my projects and honestly i've tried to manually install everything myself but i ran into a compatibility wall and missing versions so if we can somehow get the hub working as it should that would be awesome.

    EDIT: For anyone that comes across this thread i've apparently solved this for now by installing the editor manually with android and ios support. For the android sdk ndk and jdk i started the install of the editor from the unity hub and after it failed to validate (surprising) i went to the temp folder in my pc where you can find the downloaded files in separate folders.
    After this just open your manually installed editor you can use the hub to do it and just go set up the elements needed in preferences.
     
    Last edited: Oct 4, 2023