Search Unity

Unity Hub doesn't open at all

Discussion in 'Unity Hub' started by bakuganvlad, Nov 30, 2019.

  1. bakuganvlad

    bakuganvlad

    Joined:
    Dec 2, 2017
    Posts:
    104
    I've been trying to install Unity on a fresh Windows 10 laptop for an hour and nothing seems to work. I download the installer and run it, everything works fine, but when I actually double click the icon, even in admin mode, nothing happens. I can see 2 Unity processes in Task Manager, but the program itself never shows up. I don't get any error message, it simply won't do anything.
     
  2. Tindajii

    Tindajii

    Joined:
    Dec 9, 2014
    Posts:
    5
    I had the same problem yesterday. This work-around worked for me:

    Install Hub, but don't bother starting it up, it won't load (same issues as you)
    Install whichever version of the Editor you need (don't do it through Hub, do it through the Unity Download Archive..
    https://unity3d.com/get-unity/download/archive

    After it installs, let it run itself from the install window (little check box to run Unity now).
    It will immediately tell you that you need a license and force you to do this through Unity Hub. It will offer to open hub so you can give it your license. Let it open Hub. At this point Hub opened for me. I input my License and everything worked fine from the on out. So far it hasn't crashed and I haven't seen the double blank error upon creating a script.

    Hope this helps.
     
  3. Kinosei

    Kinosei

    Joined:
    Dec 3, 2015
    Posts:
    3
    I had the same issue and tried what Tindajii sugested. Installing Unity Editor and running it asks to install the Hub, it didn't asked to launch it. But after that, I could open the Hub with no problems.
    Thanks for the tip!
     
  4. suhailtaleb12

    suhailtaleb12

    Joined:
    Dec 4, 2019
    Posts:
    1
    I tried that but it asks me to install the hub, and i installed the hub again and ran the editor and still asks to install the hub even though i have it installed aleady. i dont know what to try next