Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We are updating our Terms of Service for all Unity subscription plans, effective October 13, 2022, to create a more streamlined, user-friendly set of terms. Please review them here:
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice
  4. Join us on Thursday, September 29, for a day with Unity's SRP teams here on the forum or on Reddit, and discuss topics around URP, HDRP, and the Scriptable Render Pipeline in general.
    Dismiss Notice

Unity Hub does not work unless I run as root. (Linux)

Discussion in 'Unity Hub' started by CathodeRayBlues, Oct 6, 2018.

  1. CathodeRayBlues


    Oct 6, 2018
    I am running Linux Mint 19 on an Alienware 14 laptop.
    I downloaded the .appimage, marked it as an executable file, then ran it normally. It only gives me a white window.
    I tried running it as root, and it seems to work properly, even giving me the option to integrate it into the system as an official program.
    Though since it is said that running the Unity Editor as root is a bad idea, I need to figure out how to get this Hub to work without running as root.
    The link that Unity Hub makes to the start/programs menu also doesn't do anything.
    Why does this happen and how could I fix this?
    {EDIT} I don't know how it happened but it suddenly works now. I won't complain.
    Last edited: Oct 12, 2018
  2. rcaettano


    Dec 11, 2012
    Having same issue, could not fix
  3. LocalNoob


    Mar 31, 2017
    Having the same issue!!! Please send help
  4. AbrahamDUnity


    Unity Technologies

    Jun 28, 2017
    Hi all,

    If you are experiencing this issue, could you attempt to report a bug (the Hub's bug reporter may still be operational) by clicking the "Report a bug" option from the tray menu? This will automatically attach your logs to the issue and we'll have more information as to why this is happening.

    Alternatively, here are some basic troubleshooting tips to try beforehand:
    - Make sure you are on the latest version of the Hub.
    - If you are behind a proxy, make sure to set your proxy information in the HTTP_PROXY and HTTPS_PROXY environment variables.

    If your issue persists submit a bug report and we'll investigate further.

  5. LocalNoob


    Mar 31, 2017
    Oh man I guess we installed it as sudo or something... All my unity related folders were owned by root so UnityHub couldnt start as normal user. I recursively changed permissions to my username in all of these folders and now it is fine.
    1) sudo chown username:username -R ~/.config/UnityHub
    2) sudo chown username:username -R ~/.config/unity3d
    3) sudo chown username:username -R ~/Unity/Hub #Folder in which I installed the hub(downloaded editors saved here), I guess it might be different for you, check
    4)sudo chown username:username -R for your project folders wherever you saved them
    5)sudo chown username:username -R ~/.local/share/unity3d
    6)sudo chown username:username -R /tmp/GiCache #Guess you could reboot instead idk
    7)Actually, yeah, reboot
    8)Correct me if I forgot something
    Last edited: Aug 7, 2019
  6. matuki_unity


    May 14, 2018
    Worked fine for me!
    Step 6 did not apply for me since I couldn't find GiCache folder, but it worked anyway.
  7. GrosLombaire


    May 17, 2022
    Didn't work directly for me but I checked the log files (Top left menu > Troubleshooting > Open log folder -> cat info-log.json | grep Error) and figured out that I needed 2 extra steps:

    Change another ownership
    sudo chown username:username -R ~/opt
    # I would advise setting it back to root after you're done

    And create a folder as well:
    sudo mkdir /home/username/.local/share/unity3d/prefs

    After all that it worked for me ! (maybe reboot another time)