Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Bug Unity Hub does not Launch (Critical Error Encountered) v 3.0.1 2022 (Manually Solved)

Discussion in 'Unity Hub' started by dantesryu, Mar 9, 2022.

  1. dantesryu

    dantesryu

    Joined:
    Oct 3, 2018
    Posts:
    7
    I came across this problem and finally got it solved manually and I hope this can be seen by whoever faces similar situation and save your time.

    Here is what I experienced:

    1. I tried to open a Unity project from a network shared folder and the editor did not launch correctly
      (I did not know that it was BY DESIGN NOT SUPPORTED at that time)
    2. I closed Unity Hub as usual
    3. I tried to launch Unity Hub at another time and got the error message saying
      UNITY HUB ENCOUNTERS A CRITICAL ERROR
    4. When I tried to quit and re-launch Unity Hub, it just gave me a blank window and it does not start
    5. When I check Task Manager, there are 2 or 3 Unity Hub tasks there stuck that I could not end task without doing a restart or logout.
    So I read the log and I saw:
    1. Failed with ipc error type: PipeIsNotOpen,
    2. Failed to connect to pipe: 'Unity-LicenseClient-[myname]
    3. Failed with ipc error type: PipeIsNotOpen, pid: undefined
    4. Failed to start Unity Hub, reason: Error: UNKNOWN: unknown error, open '\\\\\\\\Device\\\\Directory\\\\Directory\\\\UnityProjectName\\\\hubInfo.json'\
    If you wonder where the log is located:
    C:\Users\yourusername\AppData\Roaming\UnityHub\logs\info-log.json

    And here was what I thought:
    Unity Hub has somewhere to store its recent opened Unity Project list and Unity Hub failed to open it for any reasons (e.g. the disk is disconnected, the shared folder is disconnected, etc.). And that cause the critical error that stops Hub from launching.

    Solution
    1. Open Registry Editor (search it in your start menu)
    2. Find the folder called
      HKEY_CURRENT_USER/Software/Unity Technologies/Unity Editor 5.x
    3. Find RecentlyUsedProjectPaths (Be informed that there can be multiple if you have many projects on your Hub's list
    4. Double click or Right Click/Modify to see its path which matches the one that caused the error and delete it
    5. Try to launch again, if it does not work, re-install Unity Hub too.
    Why I consider this as a bug although I found it was by design not supported to open projects on network shared folder:
    It does not matter what it supports or not, it matters that Hub crashes if it cannot find or read a JSON file from a disconnected path. Like there are countless softwares out there that has "Open Recent" option in their File Menu, missing file should not lead to a critical error.
     
    Last edited: Mar 10, 2022
    caudras, hzhou17 and Sibylline-Siren like this.
  2. hzhou17

    hzhou17

    Joined:
    Aug 27, 2019
    Posts:
    2
    Had the exact same problem! I moved a network drive to another computer. Thank you so much for this solution.
     
  3. unity_RLd3UK3h4crf2A

    unity_RLd3UK3h4crf2A

    Joined:
    Apr 30, 2022
    Posts:
    1
    blessings on your alley!
     
unityunity