Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We've updated our Terms of Service. Please read our blog post from Unity CTO and Co-Founder Joachim Ante here
    Dismiss Notice
  4. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  5. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

Unity Hub and HiDPI

Discussion in 'Linux Editor' started by Eraph, Dec 28, 2018.

  1. Eraph

    Eraph

    Joined:
    Aug 15, 2015
    Posts:
    44
    Unity Hub adheres to my desktop's DPI settings and looks pretty great. However, when I try to open Unity (2018.3.0f2) from the Hub, the scale is back to being tiny. There are known workarounds such as setting environment variables (GDK_SCALE if I'm not mistaken) or setting the variables before opening, but these don't seem to be picked up by the editor. Any suggestions?
     
  2. DrunkenDogcow

    DrunkenDogcow

    Joined:
    Feb 7, 2015
    Posts:
    5
    You can launch the editor directly without using Hub. Hub shows you the path of any installed editors, so use that path to launch from your terminal window:

    GDK_SCALE=2 GDK_DPI_SCALE=0.5 /path/to/my/editor


    (GDK_DPI_SCALE is important because GDK_SCALE by itself will result in a oversized menubar being drawn. GDK_DPI_SCALE mitigates that.)