Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug Unity Hub 3 won't login

Discussion in 'Unity Hub' started by AndreiMarian, Aug 16, 2023.

  1. AndreiMarian

    AndreiMarian

    Joined:
    Jun 9, 2015
    Posts:
    77
    Hello.
    I have Unity Hub 3.5.0 on Windows 10. Running it as a regular user works but it can't install new editors. It downloads all the stuff but when it comes to actual installation it fails. I had to roam about the internet to find out that the reason is because it's not run as admin. So please, before attempting an installation check whether Unity Hub is run as admin and let the user know.
    Now, to the actual problem:
    I ran Unity Hub as admin so that I can install an editor but running it as admin brings me to a window with a screenshot of The Heretic and Sign in button and create account link.
    Clicking on Sign in opens an auth link in my browser and nothing else happens. Clicking for a second time it opens a second tab with a new auth link and this time an additional black window with "Unity Hub" and a throbber shows up. Nothing further happens, the throbber keeps animating indefinitely.

    My research:
    There's https://stackoverflow.com/questions/71983840/unity-hub-not-logging-in which suggests, as a temporary solution, launching Unity hub from command line with part of the uri as argument or modifying a registry entry in Windows. Tried both without success.

    From what I noticed, the Unity Hub entry in Task Manager with the command line looks nothing at all like the uri of the auth link, not even code_challenge= in the link being the same as code= in the command line.

    If I go with Create account it takes me to a page with details of my account, like name etc.

    Please suggest a working temporary solution.
     
  2. Rewaken

    Rewaken

    Joined:
    Mar 24, 2015
    Posts:
    129
    Facing same error, cant update assets which I've purchased from assetstore.