Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on March 30, 2023, between 5 am & 1 pm EST, in the Performance Profiling Dev Blitz Day 2023 - Q&A forum and Discord where you can connect with our teams behind the Memory and CPU Profilers.
    Dismiss Notice

Bug Unity Hub 3.1.2 on MacOS just shows a black empty window on opening.

Discussion in 'Unity Hub' started by Vijfwinkel, May 29, 2022.

  1. Vijfwinkel


    Dec 21, 2021
    [Solved the issue, please look at ]

    Unity Hub started showing a black empty window suddenly today.
    And as a bonus it crashes when I try to close it.

    I tried to reinstall the latest Unity Hub but all it shows is a black empty window on MacOs (Catalina).
    I tried removing every related unity folder (except my license folder) but even then Unity Hub shows that empty black screen.
    No log files, no errors, just this empty black window.
    Rebooting my mac doesn't help.

    Does anybody have any idea how to either completely remove Unity from a MacOS or fix this problem?
    I presume there is something leftover crashing even the fresh installation.

    I removed the following files/folder :
    1. /Applications/Unity
    2. ~/Library/Application Support/Unity
    3. ~/Library/Caches/com.unity3d.*
    4. ~/Library/Logs/Unity
    5. ~/Library/Preferences/Unity
    6. ~/Library/Preferences/com.unity3d.*
    7. ~/Library/Unity
    8. /Library/Application Support/Unity
    Last edited: May 29, 2022
  2. Vijfwinkel


    Dec 21, 2021
    Tried upgrading to the latest OS BigSur but still Unity Hub only shows this black screen.
  3. Vijfwinkel


    Dec 21, 2021
    Great success!

    Someone mentioned to turn off the Wifi connection and open Unity Hub again.

    I tried this and then the Unity Hub contents finally showed up.

    By the way, my license was valid and my internet connection is working perfectly fine.
    It seems that this UnityHub application is some sort of web application, getting stuck trying to show an old/outdated
    web page.

    At least I hope this will help someone else with the same problem.