Search Unity

Unity hard crashing GPU, causing system hitching, and at extreme cases crashing the entire PC.

Discussion in '2020.2 Beta' started by caseysharer, Sep 6, 2020.

  1. caseysharer

    caseysharer

    Joined:
    Sep 19, 2018
    Posts:
    2
    as stated this issue has actually been going on for some time as far as system hitching goes but has increasingly gotten much worse since trying out 2020 versions.

    I've upgraded to the latest 2020 version to see if it would absolve some of the issues but no dice.

    So as soon as I open my project in Unity immediately my system has half-second hitching every 5 seconds or so which persists outside of the editor as well until I exit out of Unity and close the Unity hub (and in some cases restart my pc entirely).

    If Unity is running for more than 15 minutes I start to get significant slowdowns on my GPU and most times all of my displays freeze completely for 1 to 3 minutes then they turn off back on and Unity crashes giving this error.

    upload_2020-9-6_12-13-25.png

    It seems Unity doesn't play well the RTX 2080 ti.
    This last round I had to open Substance Painter to re-export some textures and Unity was open then it hard crashed my PC to black.

    Again these issues ONLY happen with Unity whenever the editor is started.

    Has anyone else experienced this, have workarounds, or is there a fix in the works?

    Thanks much.
     
    Asdcxz01 likes this.
  2. AlkisFortuneFish

    AlkisFortuneFish

    Joined:
    Apr 26, 2013
    Posts:
    861
    Generally (but not necessarily), a crash means driver issues. Are you on the latest drivers?
     
  3. Lex4art

    Lex4art

    Joined:
    Nov 17, 2012
    Posts:
    333
    Works fine enough for me (452.06 game ready driver, same 2080Ti). 2020alphas/betas crashing often, but usually without freezing and rare - with freezing whole Windows but after 30-40 seconds it's unfreezes. Never got error message like yours - seems hardware problems (clean up PCI-E contacts, power cables and so on - maybe helps, maybe 2080Ti just going to die (this series has record failure rate ...).
     
  4. LeonhardP

    LeonhardP

    Unity Technologies

    Joined:
    Jul 4, 2016
    Posts:
    2,492
    Hi @caseysharer,

    Please try the following to see if it helps with the crashes and the hitching:
    - Update your GPU drivers
    - Uninstall GeForce Experience
    - Disable any app used to monitor framerate
    - Uninstall or reinstall NVIDIA Audio drivers
    - Turn off Image Sharpening:
    1. Open the NVIDIA Control Panel, and click on Manage 3D settings.
    2. Scroll down the Global Settings tab to Image Sharpening.
    3. Select the "Off" option
    If the issues persist, please submit a bug report for them, ideally with a reproduction project attached.
     
  5. steinbitglis

    steinbitglis

    Joined:
    Sep 22, 2011
    Posts:
    178
    I'm also seeing these crashes with Radeon RX 5500 XT, so i doubt that it's related to NVidia.
     
  6. D12294

    D12294

    Joined:
    Oct 6, 2020
    Posts:
    2
    I also have this crashes with PC and Mac Book and I'm afraid to use Unity now. I already spent 900€ repair costs for my Mac Book and again got it crashed... puh... that's really annoying.
     
    Last edited: Mar 14, 2021
  7. MrCool92

    MrCool92

    Joined:
    Jul 13, 2015
    Posts:
    23
    I cant get 2019.4 with HDRP 7.5.1 to open and import with 2020.3.

    System out of memory message pops and then GPU crashes, all during HDRP material upgrade/import process.
     
  8. eslam-aboalo

    eslam-aboalo

    Joined:
    Feb 1, 2015
    Posts:
    1
    I also have this crashes, and no massage just pc is shut down, with PC Win10 I7 Unity 2020.2.7f1 GeForce 680
     
  9. D12294

    D12294

    Joined:
    Oct 6, 2020
    Posts:
    2
    Perhaps it is because no targetFrameRate is set and the GPU utilization is therefore always 100%, the CPU utilization is also high and the hardware is overheating as a result. Without a target frame rate, the fps are uselessly high in my application with over 1500 fps. With the targetFrameRate of 60, the GPU and CPU utilization was in the low double-digit or even single-digit range.

    These two lines at the start of the application could help.

    Code (CSharp):
    1.         QualitySettings.vSyncCount = 0; // If this setting is set to a value other than 0 (Don't Sync), the value of Application.targetFrameRate will be ignored.
    2.         Application.targetFrameRate = 60;
     
    Last edited: Apr 28, 2021
unityunity