Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Unity game windows maxes out at 80-90 fps?

Discussion in 'Editor & General Support' started by MrSecretMansion, Feb 22, 2016.

  1. MrSecretMansion

    MrSecretMansion

    Joined:
    Nov 17, 2013
    Posts:
    113
    Basically, whenever I go to the game window to test my game it always maxes out at 80-90 fps. This happens on all my projects, as well as most example/complete projects. Here is my setup:
    AMD FX-6300
    8GB of RAM
    MSI GTX 760 MINI
    MSI 970 Gaming Motherboard
    Windows 10
     
  2. Antony-Blackett

    Antony-Blackett

    Joined:
    Feb 15, 2011
    Posts:
    1,282
    Do you have v-Sync on in the quality settings? If so, turn it off.
     
    MrSecretMansion likes this.
  3. MrSecretMansion

    MrSecretMansion

    Joined:
    Nov 17, 2013
    Posts:
    113
    I did not think about that, I will try it after school tommorrow and report back.
     
  4. Yo123

    Yo123

    Joined:
    Aug 31, 2012
    Posts:
    4
    With the game running in the Unity IDE, press Ctrl-7 to get the Profiler. As long as there is an item called 'WaitForTargetFPS', it's running flat out. As you load your game up that should squeeze out to zero, then you should begin to see the overall frame rate drop.
     
  5. MrSecretMansion

    MrSecretMansion

    Joined:
    Nov 17, 2013
    Posts:
    113
    Disabling vsync solved my problem! Thx